I have three files that are supposed to be disks image with a .img extension. However, when I look at their properties, Windows says that it's just a file, without any extension. I tried to manually put .img at the end of the file's names, and thus turning them into supposed IMG files, but it didn't work.

Does anyone know how I can open it ? I tried Daemon Tools and IMG to ISO converters, but nothing worked.

  • Were they originally supposed to have a .img extension? Disk images can come in different formats. – David Houde Jun 14 '13 at 9:31
  • @DavidHoude Yes, they were. I've got another image coming from the same set of files with a .IMG extension, and they come from the same DVD making software. – Pollux Jun 14 '13 at 9:45
  • 1
    Sounds like the files may be corrupted. – Ƭᴇcʜιᴇ007 Jun 14 '13 at 12:13
  • I believe the .img extension is overloaded, that is, there are multiple distinct formats using that same extension. Do you know what the actual format of the files is, e.g., which program created them originally? – Harry Johnston Jun 17 '13 at 2:43
  • For example, might they actually be Macintosh disk image files? That might explain the lack of an extension ... – Harry Johnston Jun 17 '13 at 2:44

You might try 7-zip or another archive software. It could maybe manage to open it. If not, it could be interesting to see the first bytes of the file which can indicate which format it is.

They could as well be corrupted.

  • Tried 7-Zip and WinRAR, didn't work. I you want to see the first bytes, tell me how to get them. And I don't think they're corrupted because I actually saw their content displayed. – Pollux Jun 14 '13 at 17:48
  • i guess these files are to large to share over the web. try to get head.exe (from unxutils.sourceforge.net) and do: head yourfile > yourfile.head. Then open it with a classic editor or an editor with hexadecimal view, and let us see what's the beginning. (i have no idea if it'll be helpful, but it's worth trying) – pataluc Jun 14 '13 at 21:15
  • I downloaded head.exe, but when I type head [my file], it just prints head [my file] – Pollux Jun 15 '13 at 15:18
  • it's strange, you should get something like this: C:\WINDOWS\system32>head xcopy.exe MZÉ ♥ ♦ © @ Ó ♫▼║♫ ┤ ═!©☺L═!This program cannot be run in DOS mode. $ AÉ╣Õ♣±ÎÂ♣±ÎÂ♣±ÎÂã■ÏÂ♦±ÎÂ♣±ÍÂá±ÎÂã■è±ÎÂã■ê – pataluc Jun 17 '13 at 8:35
  • nope, whenever I launch it I just have an empty console window. – Pollux Jun 17 '13 at 11:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.