I need a bit of help with my System. It worked without problem for around 2 years but yesterday and today, I am getting lock-ups and BSODs in random intervals.

From what I could tell the fault seems to be with data getting loaded into or from the kernel. I have 4 bluescreens which seem to tell me either that the cables connecting my harddisk are somewhat loose or broken (seems unlikely, they don't seem loose, and I haven't rearranged them at all in those nearly 2 years), or sth. else, from what I have seen on the official MSDN article.

If anyone here has sufficient experience, I'd really like to know what the most likely problem is that leads to this Bluescreen.

Sadly I cannot do a memtest86+ right now (or anything else before booting) since I use a USB keyboard which is not recognized before Windows starts. I'll try to get a good ol' PS2 keyboard as soon as possible to do some investigation in this direction too.

Thanks in advance!

Some Info on the used System:

Windows 7 64bit with all updates 8GB RAM Intel Core i5 2.500K CPU @ 3.3Ghz

If anything else is needed, ask and I shall provide :)

Seems fixed, this was my Problem

I have a Crucial M4 SSD and for now, it seems all my problems came from the '5000h' bug. I updated the firmware and this seems to have fixed the problem.

  • We cannot help you until you ran the Memtest86+ Because without you telling us its not the memory we cannot rule possible causes. Furthermore you should post the crash dumps they contain lots of good information we need to help you. – Ramhound Jun 15 '13 at 12:37
  • Sadly, the system seems to not write any dumps. I checked C:/Windows/Minidump which is empty. I set the system to record dumps (small memory dump - 256kb) but for whatever reason it won't create one. I will do a memtest as soon as I can buy another keyboard and update the question with the results then. – random_error Jun 15 '13 at 15:34
  • In the future if you don't get memory dumps you know its the storage device( in general ) causing the crash. The reason for this is because Windows is unable to write the crash file on a storage device that caused the crash. – Ramhound Jun 17 '13 at 11:33


C:\Users\André>err 0xc000009D
# for hex 0xc000009d / decimal -1073741667
  STATUS_DEVICE_NOT_CONNECTED                                    ntstatus.h
# as an HRESULT: Severity: FAILURE (1), FACILITY_NULL (0x0), Code 0x9d
# for hex 0x9d / decimal 157
  ERROR_DISCARDED                                                winerror.h
# The segment is already discarded and cannot be locked.
# 2 matches found for "0xc000009D"

Check the SATA cables and make sure you use the latest firmware for your SSD.

  • I'll accept this answer though I solved the problem myself, because it was actually a firmware issue. I have a Crucial M4 SSD and for now, it seems all my problems came from the '5000h' bug. I updated the firmware and this seems to have fixed the problem. – random_error Jun 15 '13 at 20:51
  • 1
    ok that's why I asked for the firmware. Several SSDs have such strange issues which several firmware version. Nice to hear that you fixed it :) – magicandre1981 Jun 16 '13 at 5:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.