A friend gave me a corrupted USB memory stick to try recovery data from. But I've had some unusual results, so thought I'd share to see if anyone is familiar with this problem...

  • First off I just tried opening from my own PC. Windows prompted to Format the drive, which I of course declined
  • Downloaded TestDisk to anaylsis the drive. And right away I noticed something strange, on the listed drives it comes up as

Disk /dev/sdc - 6144 B - USB Flash Drive

  • That's right, the first USB flash drive smaller than a floppy disk!?
  • Moving on anyway... first anaylsis comes up with:

Partition sector doesn't have the endmark 0xAA55

  • TestDisk's Quick Search gave no results, moved on to Deeper Search:

No partition found or selected for recovery

  • This left me stumped. I tired a couple of other programs with no success
  • I did manage to get a backup image, but it was just as small as TestDisk indicated, so nothing of use on it
  • After a few hours trying various suggestions from other sources, I gave in and just tried formatting the drive. But returned the message:

Windows was unable to complete the format.

  • From googling that, the suggestion was to delete the partition. But there is no partition to delete in this case.
  • most recently I've tried formatting from cmd, and got this result:

Format D: /FS:FAT32

The type of the file system is RAW

The new file system is FAT32

Verifying 0M

11 bad sectors were encountered during the format. These sectors cannot be guaranteed to have been cleaned

The volume is too small for FAT32

Anyone got any suggestions?

UPDATE: As per suggestion from @Karen, I tried running a CLEAN from DISKPART, results as follows

DiskPart has encountered an error: The request could not be preformed because of an I/O device error.

  • 2
    Try diskpart, select the correct disk, then clean, or try something like GParted from Linux. OTOH all those bad sectors probably mean the drive's a goner.
    – Karan
    Jun 15 '13 at 15:33
  • @Karen GParted didn't even see the USB device. I tried Diskpart and updated my question with the results. Thanks for your suggestion.
    – Skytunnel
    Jun 15 '13 at 16:25
  • 1
    DiskPart has encountered an error: The request could not be preformed because of an I/O device error. That's not a good error to get; something's happening at the hardware level (either in the firmware of the USB drive, or the flash memory itself is corrupted). Either way, I'd say that drive is toast now... Sorry :( IMHO, if you can't get anything back with TestDisk, and you can't even format the drive because of I/O errors, time to get a new one... If you want to do a sector check, you can try doing a chkdsk -r on it, or a full format. Jun 15 '13 at 16:25
  • @Breakthrough ah okay, thanks for explanation. At least I don't have to spend anymore time on it :). I'll go break the bad news to my friend.
    – Skytunnel
    Jun 15 '13 at 16:27
  • You can try this , just saying, it could help. Dec 19 '15 at 8:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.