I have a program that I can't uninstall. I get the following error:

There is a problem with this Windows Installer package. A program required for this install to complete could not be run. Contact your support personnel or package vendor.

The program seems to be completely romoved from Program Files except for 2 files, Which is a LaTeX log file:


When I try to manually delete these files I get:

You need permission to perform this action

I click "Try Again" multiple times and it never succeeds.

When I run command prompt as administrator and try:

del C:\Program Files (x86)\dir\QuoteTemplate.log

It says Access is Denied. If I try:

cd C:\Program Files (x86)\dir

It says Access is Denied.

I thought that a corrupted program had a lock on the file, so I restarted the computer, then did all of the above again, with the same results.

Update: starting in safe mode and doing the same had the same effect.

Update: I was able to change the content of the files, I just couldn't delete them. I believe it to be because of the access permissions on dir. I was able to unlock dir using unlocker from the accepted answer. It seemed that windows explorer somehow had a lock on the file, which is why restarting didn't fix the problem. I could be wrong though.

Any ideas?

marked as duplicate by Ƭᴇcʜιᴇ007, Breakthrough, soandos, Mokubai, nixda Jun 16 '13 at 10:02

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Who is the owner of those files? Have you tried to change owner to your account? – gronostaj Jun 15 '13 at 17:26

A simple tool, called unlocker can do the job easily, it disables all the 'you cannot delete ...' restrictions

  • 2
    the tool is also available at its website – user1055604 Jun 15 '13 at 20:45
  • yeah better use that one , cnet always wants to install stupid toolbars and stuff together with your software – arvan08 Jun 16 '13 at 9:20
  • Thanks a ton. This solved it for me. FWIW I downloaded from the unlocker website because cnet tried to get me to download 3 extra 3rd party toolbars etc. I edited the link in the post to point to the better link. – ajon Jun 17 '13 at 14:28

Use TAKEOWN /F filename /A to define the Administrator group as owner of the file. Then try again deleting the file as Administrator.

Another option would be to repair the access rights of the file using ICACLS.

  • TAKEOWN said it was successful, but still didn't let me delete it. I don't think I correctly figured out ICACLS. That might have fixed it, idk. – ajon Jun 17 '13 at 14:30

Execute the uninstaller EXPLICITLY as Administrator (not just simply running the program on an account that has adminitrator privs). Otherwise you get this type of error. I have had this happen on installs several times, and running the program as Administrator fixes the problems.

Not the answer you're looking for? Browse other questions tagged or ask your own question.