2

I have a problem with Spotlight : When I start typing the name of an app, its icon is usually the c file header's. For example, for the Activity Monitor :

How can I restore the real icons instead ?

Regards.

PS : I'm using OS X 10.8.4

0

This maybe not the right answer but you can re-index your spotlight folders or you whole volumes, follow this link for instruction. I also recommend you to use Alfred App. It's a best spotlight replacement, IMHO.

  • I tried this method : it indexed my volume again but my icons are still the objective c's ones. This applies for all the apps I type in Spotlight. – Jonas Jun 16 '13 at 11:41
  • Is it open with XCode or open your app correctly? Have you try Alfred app? – attomos Jun 16 '13 at 13:56
  • It opens correctly. It's just the icons that are not corresponding to the app. I didn't try Alfred as I want to use Spotlight. – Jonas Jun 16 '13 at 15:17
0

You should give some of the suggestions here a try: http://osxdaily.com/2007/02/15/spotlight-wont-work-fix-a-broken-spotlight-menu-with-these-troubleshooting-tips/

I was also seeing Objective-C icons for all my apps after migrating to a new laptop.

I tried rebuilding my Spotlight index, but that didn't seem to do anything. But killing SystemUIServer fixed it for me.

Note: I'm running OSX Mavericks (10.9)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.