1

I've just installed DD-WRT (DD-WRT v24-sp2 build 21676) into my TP-Link (TL-WR1043ND) router. I've setup port forwarding for port 80 to my machine port 80 and it works well under LAN access (checked from my PC and cellphone connected to LAN).

I'm trying to access the testing server from outside through a web proxy, and other sites that check whether my public IP is up, but I can't figure out why I'm unable to access from outside while LAN access is fine.

Server is on OS X Mountain Lion with disabled firewall.

Any help?

I've find it strange to not have an Hairpin NAT issue (I'm able to access the server from LAN through the public WAN address), which is generally a common problem, but still, have this issue.

EDIT1

I've used a web based port scanner and it tells me my serving port (9999, not 80) is open (other ports are not), even though I'm unable to browse it.

EDIT2

I've learned people can access my server on 9999 port from outside! Now I don't understand why I'm unable to access it with the web proxy tools I've tried.

How can I check, from my machine, that it's serving content correctly, with the help of some online tool or proxy that would access it from outside?

0

Well first step is that we find where the problem is happening please fallow this steps

  1. Open cmd (Press Win+R then in the text box type cmd and press OK)
  2. On cmd type "tracert /IP" eg. tracert /0.0.0.0

it will give you a list of connections you can find out where it stops with that list

other tool that i use it for testing my connection to other servers http://www.hlsw.org/hlsw/download/ it's for games but it has good tracing tool

  • online trace tool gives me this i.imgur.com/cSqet4g.png for my IP. Server is hosting on port 80 and working locally. – pepper_chico Jun 16 '13 at 15:29
  • also, changing my port to 80 for hosting turn it closed at yougetsignal.com/tools/open-ports, but leaving it as 9999, for example, leave it open. I can't access in both cases, but I suspect it turns out closed for port 80 maybe because of ISP blocking. – pepper_chico Jun 16 '13 at 15:38
  • As the image shows your ISP is blocking the port since trace ends at your ISP you need to find other ISP or a new port i hope my post helped you – poqdavid Jun 17 '13 at 11:42
0

The web proxies I've tried and online traceroute tools were to blame, the only reason I can think for them not to be able to access it is because they won't access non-standard ports.

I've then tried an online shell and run curl <myip>:9999 and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.