0

Yesterday my sata HD (western digital) on my windows 7 desktop PC suddenly became really slow, and Windows hanged, which led to a failed shutdown. I ran whatever automatical repair Windows suggested when i restarted the computer. After that, things became only worse.

Frist thing upon booting after that, BIOS (smart) warns about imminent failure on the HD, attribute 5.

Windows bootloader does load, and Windows load process starts, but then there is an I/O error and an error message suggests the HD is not plugged in properly (i have tried 3 different SATA cables).

I tried accessing the HD from a linux machine. Running ntfsfix gives no errors, however when i try to mount the partition with the data I would like to recover, im getting lot of error messages like this:

exception Emask 0x0 SAct 0x1 SErr 0x0 action 0x0
irq_stat 0x40000008
failed command READ FPDMA QUEUED
cmd 60/01:00:9d:26:e5/00:00:01:00:00/40 tag 0 ncq 512 in
res 41/40:00:9d:26:e5/00:00:01:00:00/40 Emask 0x409 (media error) <F>
status: {DRDY ERR}
error: {UNC}

The HD has Windows 7 on it, I have tried different SATA cables, 2 computers.

I tried googling about the issue, to no avail. Is there something else i can try to recover the data? The only working OS i can currently plug the HD in is ubuntu linux.

  • Have you tried mounting it read-only under Ubuntu? – gronostaj Jun 16 '13 at 19:39
  • First off, if you SMART status is pre-failure or failed, it is very likely that your drive is toast, or dying very quickly. Not all smart stats are created equal, so Attribute 5 may be less fatal, but without knowing which metric it is, its hard to tell. that you are getting manifest errors and smart indicators of prefail together however does point to big problems. speedfan can display the details of the current SMART stats. – Frank Thomas Jun 16 '13 at 19:59
  • Mounting read-only gave the same error messages, thanks anyway. – user231632 Jun 17 '13 at 16:15
2

Attribute 5 is Reallocated_Sector_Ct. This is bad. Your hard drive is low on or out of spare sectors to reallocate, so any sectors that develop errors will be exposed directly to the system. Consider yourself lucky if you can scrape any data off it, then toss it.

0

Stop trying to do anything on that drive!

You may have already damaged it further by your attempts to run 'whatever automatical repair Windows suggested'. Of course 'After that, things became only worse'.

After having said that (especially for others reading along for who it is not yet too late) put it in another computer as a secondary disk and try to make a disc copy of it. Nothing should write to the disk, maybe use a linux system to make sure of that. From that copy you can try to recover data. For specific instructions for these two steps, search SuperUser or the net in general.

If after that you still desperately need data from the bad drive, either bring it to a disk recovery service, or if you insist on doing it yourself, run Spinrite on it. But before buying that, I suggest you ask its author (Steve Gibson) if it will help in your situation - I don't know what it will do in the case where the SMART subsystem is really out of spare sectors.

  • Thanks for your insight, obviously I realized too it was a mistake to try that Windows repair and I have been trying not to write anything on the disk after that. I hope I didn't screw it any further with ntfsfix or mounting though. – user231632 Jun 17 '13 at 16:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.