5

Okay here's probably an easy one for anyone familiar with Ubuntu.

I have installed NodeJS (v.0.10.10) and NPM. I ran:

sudo npm install -g grunt-cli

and

sudo npm install -g grunt

(in every combination)

but although everything seems to install successfully, i.e. I see in /usr/lib/node_modules the grunt-cli folder and I navigate to the bin, and see the grunt exe, when I try to type grunt, I don't get any errors, but just nothing except the next command line prompt.

BTW - I've tried installing jasmine-node globally as well with the same results.

I installed npm and nodejs from Chris Lea's PPA.

2
  • 2
    SOLVED: solution was to uninstall node: sudo apt-get remove node – user2486236 Jun 14 '13 at 14:03
  • 2
    sweet, can you post that as an answer to your question, accept it as the official answer, and that way people know not to reply :) – balupton Jun 14 '13 at 14:14
6

The solution was to uninstall the "node" package:

sudo apt-get remove node

Note: This is a completely different package than the stable release version of Node.js.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.