3

I am attempting to load a project from Visual Source Safe onto my Windows 7 32-bit machine in Visual Studio 6.0.

Everything is successful except for an error that occurs in finding this "MSComCtl2 DLL"

it creates a log file with the name of each form that uses a date-time picker. The log file states:

MSComCtl2.DTPicker of control ... was not a loaded control class

with the name of the variable name of the control in place of the ellipsis.

I thought it would be a simple fix to just download or register the MSComCtl2 DLL but I cannot find it anywhere.

I tried downloading and applying the Common Controls DLL (Platform SDK Redistributable) and http://www.microsoft.com/en-us/download/details.aspx?id=24417 but it made no difference...

What should I try next?

  • You seem to have copied the shortened text of the link and not the actual URL, so it's naturally broken. Anyway, try installing this (right-click and run it as admin) and see if it helps. – Karan Jun 18 '13 at 5:14
2

I bet you have Visual Studio 2010 or something installed. The .Net framework causes some conflicts. You are going to have to uninstall 1 or the other.

-1

I've solved the problem this way:

Search for the "MSComCtl2 DLL" and copy over the same path as the .vbp project. Then try to re-open the project.

If this fail, register the file (in that path) usign RegSvr32.

Work for me!

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.