3

How do I install vagrant alongside a specific version of ruby installed using RVM?

I have both 1.8.7 and 1.9.3p429 installed. After using RVM to set my default to 1.9.3 I no longer have vagrant available. I could re-install using "gem install vagrant" but this is out of date and doesn't use the providers options.

0

Vagrant has shifted to using system packages as of version 1.1. So, how to use vagrant along-side RVM? RVM comes with the ability to wrap executables and run them with a specific ruby/gemset.

$ rvm wrapper system --no-prefix /path/to/vagrant

Where vagrant is the executable vagrant that was installed by your package manager.

|improve this answer|||||
0

Use the latest version of vagrant installer from http://downloads.vagrantup.com/, it puts vagrant binary in /usr/bin/vagrant which should be always in PATH.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.