To start things off I am using a PC on a network with my own Active Directory login, but when I say Admin Account I mean I'm using the network's AD Administrator account.

I'm trying to edit my Hosts file in Notepad which I do regularly for testing something, as it requires elevation I have created a shortcut that always requests an elevated account.

This was all working fine until today, when it started appearing to accept the Admin login but then instead of opening Notepad it came back with a message of:


The requested operation requires elevation.


If I type the Admin login's password in wrong I just get bounced back to try again, the moment it's right UAC disappears as if it was successful, and that pops up instead.

I haven't changed anything on the Admin's rights on the server, and can log into any machine perfectly well as the Admin, but when fully logged in as Admin while it looks like I can launch Notepad + Hosts through "Run as adminstrator", if I try to save I can only Save As like a normal user would.

There's also an icon on the desktop for a program that was installed requiring elevation at the time that I cannot now delete via UAC from my account using Admin, or on the Admin's desktop itself.

PC is Win 7 Pro, Server is 2008 R2 Standard. Any help that avoids reinstalling would be greatly appreciated!

  • The only explaination that explains this behavior is that the rights actually were changed. – Ramhound Jun 18 '13 at 15:18
  • I've tried using my username (which has insufficient rights) in the UAC and I get the same sentence, but as an error in the bottom of the UAC window with it awaiting me to enter another account's details, it doesn't return to desktop then pop up an error window like Admin's does. – Dave Jun 18 '13 at 15:35

It sounds like the permissions changed, which affects that Admin account you are using.

I used to support about 2 dozen VMs at my last shop, and the way we got around not being able to save the Hosts file was to make a copy of it in a different folder, make the changes there, than copy and overwrite the original. Modifying a file in the folder requires elevated permissions, whereas simply copying and overwriting does not.

To help facilitate this, I created a batch file that would copy the file to the current users desktop if it didn't already exist there, and if it did exist, then it would move it back. That way I could double-click, make the changes, save it, then double click again and I was done.

It's not elegant, but it's fast and easy.

| improve this answer | |
  • 1
    Thanks for the idea of copying over it but unfortunately trying it here it just results in the same sort of problem, UAC pops up when I try to overwrite it, takes the login info then fails on the same error. – Dave Jun 19 '13 at 9:40
  • 1
    Dang! I was hoping that would help. We must have set UAT lower, it's been a while since I was working there. – Taegost Jun 19 '13 at 15:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.