This last week or so I have experienced problems being able to load github.com yet it loads fine on my phone, my Win7 laptop which are all connected over the same network. It wont work again until I restart my Mac Mini.

Chrome reports

The server at github.com can't be found, because the DNS lookup failed. DNS is the network service that translates a website's name to its Internet address

Same applies to Safari and Firefox. I also tried Pinging github.com and it never manges to resolve to an ip.

ping: cannot resolve github.com: Unknown host

To further complicate things dig github.com succeeds:

; <<>> DiG 9.8.3-P1 <<>> github.com ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 6490 ;; flags: qr; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION: ;github.com. IN A

;; ANSWER SECTION: github.com. 121 IN A

In Chrome I then tried to go to and it worked! And to top it off if I try going to github.com it works after doing this. Although this only works for so long before I have to do it again or restart my mac.


Sounds like a DNS problem to me - check your DNS settings in System Preferences: Network > Wi-Fi (or whatever connection method you're using) > Advanced > DNS

Try setting the DNS Servers (left pane) to and (Google's DNS servers).


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.