After upgrading to OS X 10.9 Mavericks, ant is no longer on my path.

[126] 11:23:26 rkarl-mba-4:~/mobile-baselayer > ant
zsh: permission denied: ant
[126] 11:23:50 rkarl-mba-4:~/mobile-baselayer > which ant
ant not found

I tried installing through homebrew

[126] 11:23:09 rkarl-mba-4:~/mobile-baselayer > brew install ant
Error: No available formula for ant

It's odd that homebrew doesn't have a formula for that....

After googling, I found this article, which suggested using a user's custom formula for brew.

[1] 11:23:56 rkarl-mba-4:~/mobile-baselayer > brew install https://raw.github.com/adamv/homebrew-alt/master/duplicates/ant.rb

curl: (22) The requested URL returned error: 404 Not Found
Error: Failure while executing: /usr/bin/curl -f#LA Homebrew\ 0.9.4\ (Ruby\ 1.8.7-358;\ Mac\ OS\ X\ 10.9) https://raw.github.com/adamv/homebrew-alt/master/duplicates/ant.rb -o /Library/Caches/Homebrew/Formula/ant.rb

Any help would be appreciated!


6 Answers 6


It looks like the alternate repository was migrated. You can either enable the homebrew alternate repository or install directly after updating your brew:

brew update
brew install ant
  • 7
    brew install homebrew/dupes/ant also works.
    – Jess
    Oct 22, 2013 at 23:41
  • 23
    as of today, you just need brew install ant
    – awenkhh
    Oct 23, 2013 at 12:55
  • 4
    Just as an aside: if you already have Homebrew installed (as I did, from a while back), make sure you perform a brew update before you try the accepted answer or else you may get a 404 error. It is good policy to update your formulas before install but I might have let that slip my mind...
    – Matt Ray
    Oct 23, 2013 at 14:30
  • 4
    I had 404 even after update. I've tried: brew tap homebrew/dupes and then brew install ant and worked. (Source: blog.xk72.com/post/53124504531/… )
    – helios
    Oct 29, 2013 at 13:45
  • 1
    @awenkhh But this gives ==> Downloading http://www.apache.org/dyn/closer.cgi?path=ant/binaries/apache-ant-1.9.2-bin.tar.gz. Error: Couldn't determine mirror. Try again later. While the URL mentioned in that error message loads find in the browser.
    – avernet
    Nov 3, 2013 at 23:22

Upgraded to Mavericks this morning and found "command not found: ant"

brew update

Ran the the update and then tried to install ant.

brew install ant

Ant was installed, but it also yeilded this alert:

Warning: No developer tools installed. You should install the Command Line Tools. Run xcode-select --install to install them.

xcode-select --install

Now, everything is running fine.


As an alternative to Homebrew, you can always download a binary distribution of Ant from http://ant.apache.org/bindownload.cgi. It works fine on OS X Mavericks.

Just download it, unzip/untar it, and add its bin directory to your PATH.


The sequence that worked for me:

xcode-select --install
brew update
brew install ant
  • It works, but I get: "Warning: A newer Command Line Tools release is available Update them from Software Update in the App Store." but there are no updates on the app store.
    – Bram
    Nov 27, 2013 at 18:21

I usually install ant via Homebrew. There is a pretty good documentation .

Good luck.

  • 2
    That post doesn't even recommend itself anymore!
    – matt burns
    Nov 21, 2013 at 14:17
  • I followed the documentation and it worked for me.
    – pushya
    Jul 29, 2014 at 18:15

I had ant installed before upgrading to Mavericks. Afterwards, ant didn't work at all. The ONLY thing that worked for me was this:

brew uninstall ant

brew install ant

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.