I am trying to format a PC. If the brand and model are needed let me know in the comments. I tried installing Windows 7 but during the expanding Windows files step the computer froze. So I forced a reboot. Now I get the error

the file is possibly corrupt. The header checksum doesn't match the computed checksum.

I decided to fall back to Windows XP but I get the error

Couldn't find NTLDR.

Note that both errors appear right after press any key to boot from CD/DVD and both Cs are original and work on other PC.

Tried booting from a live CD of Ubuntu (very old version that requires only 256MB of Ram) and during the loading screen it went to a black screen with a horizontal cursor blinking.

As it seems I cannot run any OS nor install one. The errors do not appear if I choose not to boot from CD.

If I don't boot from CD, I get boot manager missing error. The odds are faulty ram or faulty dvd drive?

According to ComputerHope The main reasons for the NTLDR missing error are

  1. Computer is booting from a non-bootable source.

    Not Present Because I am trying to boot from original CD of Windows XP, similarly with Windows 7

  2. Computer hard drive is not properly setup in CMOS.

    Hard Drive was already setup I am trying to perform a format

  3. Corrupt NTLDR and NTDETECT.COM file.

    Windows are not present on the hard drive at all. I started a format, wiped the Hard Drive Clean. The error started occurring after restart

  4. Misconfiguration with the boot.ini file.

    Same with number 3

  5. Attempting to upgrade from a Windows 95, 98, or ME computer that is using FAT32.

    The computer already had Windows XP. Tried to upgrade to Windows 7, failed, tried to fall back to Windows XP Failed again

  6. New hard drive being added.

    Hard drive was already present. Unplugged and replugged during faulty optical drive (DVD Drive) replacement. The computer is running AMI Bios and the hard drive can be "seen" inside the Bios

  7. Corrupt boot sector or master boot record.

    Don't know what that means or how to test it

  8. Seriously corrupted version of Windows 2000 or Windows XP.

    Both are missing, the Hard drive is wiped clean

  9. Loose or Faulty IDE/EIDE hard drive cable.

    The Hard drive is a SATA drive, unplugged and replugged for testing purposes. It still happens

  10. Failing to enable USB keyboard support in the BIOS.

    Keyboard and mouse are both PS/2

Tried installing Windows XP from a usb again and I get error

".SIF file used by setup is corrupted or missing: Value 0 on the line in section [SourceDisksFiles] with key "SSA.EXE"

  • It sounds like that computer is in a totally unusable state, and probably needs a fresh install. Are you saying that when you boot from the XP installation CD, you get an error saying "Couldn't find NTLDR", or is that something that happens after the installation is completed, and the PC is rebooted? Jun 20, 2013 at 22:33
  • @NatefromKalamazoo: See his last sentence.
    – Karan
    Jun 20, 2013 at 22:33
  • 2
    Try using GParted. If that fails as well test the HDD, RAM etc. thoroughly.
    – Karan
    Jun 20, 2013 at 22:34
  • Second that, try a non-Windows live CD for testing purposes: ubuntu.com/download/desktop Jun 20, 2013 at 22:37
  • 1
    @JohnDemetriou: Try with a newer Linux version, or with the Debian-based GParted LiveCD. Also try a PS/2 KB as Mark suggested. If that doesn't help try thoroughly testing and then completely erasing the drive after connecting it to another PC. If all this fails you'll have to get all your hardware tested to see what's at fault.
    – Karan
    Jun 21, 2013 at 15:55

3 Answers 3


Have you changed any BIOS settings recently? If so, I would try setting the BIOS back to default to eliminate any issues that may come about due to wonky settings.

I would then suggest using the GParted LiveCD to boot and attempt to format the HDD. If it doesn't want to format or work using this LiveCD then it could be possible that the HDD is no good. If you can't boot into the LiveCD, I would then try booting without the HDD plugged in at all to see if the problem still exsists.

Finally, just to make sure that your RAM is okay, I would suggest creating a Memtest86+ boot CD/USB and running it for at least 24 hours. This should eliminate any doubt about the health of the RAM.

EDIT: You could also try making a LiveUSB instead. Just to test your theory of faulty DVD drive.

  • As I said before my process was this. Tried to format the HDD and install new Windows. The computer froze so I restarted. Now I get this message every-time I boot from CD. If I boot from HDD I simply get boot manager not found error because the HDD is wiped clean. I will try the Memtest suggestion you provided but before answering a question, read the question Jun 24, 2013 at 7:15
  • How about the BIOS settings? Or trying to boot the LiveCD without the HDD plugged in? What about running a LiveCD that isn't "old"? You could also try reading an answer fully before dismissing it. Jun 24, 2013 at 7:19
  • First of I apologise if I sound a bit as I am attacking you but this error is really annoying to me. Anyway, I tried restoring bios to the Optimal Defaults (it's AMI Bios) nothing changed. I changed the HDD with one of my own that I had in an external enclosure, it seems that the error is persistent regardless of the HDD. By the way, I can't vote you up because I have no reputation left Jun 24, 2013 at 7:30
  • It could be worth looking into the possibility of it being a bad DVD drive. I would suggest creating a LiveUSB at this point with something small on it like GParted or DamnSmallLinux. Jun 24, 2013 at 7:38
  • The problem is the DVD drive is completely new. (or should I say store bought, doesn't always mean new) I will try PartedMagic is that a good choice? Jun 24, 2013 at 8:18

After numerous tries and errors 4 different usb sticks I finally managed to format the PC and the error is nowhere to be found. I performed a usb installation of Windows XP. Now everything works perfectly. I do not understand why the error appeared, I do not understand why 3 of the usb sticks did not work on the usb installation. Fourth time was the charm I guess. The problem has been fixed, or should I say no longer appears. No hardware had any issues after all. The only thing needed was Windows XP that included a SATA Driver


Can you boot from your CD drive? It's possible that it's foobared, or partially so if you can read from it.

  • You said it "no longer appears" which may mean that you just aren't using the device where it fails. Although I missed that you had to use 4 different USB sticks. I would keep a close eye on your computer and ensure that you backup often. There could be HW failure in your future.
    – Adrian
    Jun 28, 2013 at 17:44
  • Basically the problem was that I added a new DVD Drive and tried to format at the same time. Had use Windows with sata driver included through a USB Installation. That was the issue. But thanks for the tips Jun 28, 2013 at 18:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.