Windows 7 Professional 64 bit
Xeon E31270 3.40 GHz CPU
16 GB of RAM
Chrome Version 27.0.1453.116 m

NVIDIA Quadro 2000 1GB
Total available graphics memory 8938 MB
Dedicated graphics memory 1024 MB
Dedicated system memory 0 MB
Shared system memory 7914 MB

About 10GB available RAM (5GB Free, 5GB cached)

The Windows Performance Information gives 7.0 (of a possible 7.9) on my graphics.
Windows Experience Index:
Graphics: Desktop performance for windows Aero = 7.0
Gaming graphics: 3D business and gaming graphics performance = 7.0

H264 files play ok if they are just started and viewed normally.

If I click on the time line with my mouse, the video goes black and needs to be reset to get it back.

It usually takes a few frame changes before it goes black.

The same thing happens if there are HTML5 video controls on the page and I use them to jump around.

The problem occurs with every H264 file I've tried, it doesn't happen with WebM files.

Here's a sample file:

If you view that link with Chrome, it loads an mp4 file: H264 MPEG-4 AVC (part 10)(avc1)

If you view it with Firefox, it loads a WebM file: Google/On2's VP8 Video (VP80)

I downloaded both and played them in Chrome. The WebM file has no problems when I jump around on the timeline, the H264 file goes black within a couple of frame jumps.

I spent a good amount of time searching for an answer, but haven't even found an article that mentions a similar problem, there were some results about H264 not playing, but not about problems when jumping around on the time line.

And of course there were tons of results about the saga of H264 and whether it would be supported by various browsers.

Any suggestions?

Can I provide additional information that would help to determine the cause of the problem?

  • Does it happen when you play other H.264 videos in the browser or with WMP? Have you tried downloading the MP4 and playing it in WMP/VLC? Perhaps related to the other question (superuser.com/questions/540025/…): tracked here code.google.com/p/chromium/issues/detail?id=221542 – Bala Sivakumar Jun 23 '13 at 5:22
  • @BalaSivakumar Thanks, the symptoms in the Superuser question you linked to were different, but I tried enabling the "Disable hardware-accelerated video decode" chrome flag and it fixed the problem. If you create an answer explaining how to access the chrome flags and enable that flag, I'll be happy to accept it. – codewaggle Jun 23 '13 at 6:44
  • Glad it worked out. I think the root-cause and the issue is the same (even though the symptoms are slightly different). I think the question should be marked as a dupe of the other one I linked since I didn't really provide an answer (merely linked to the other one) :) – Bala Sivakumar Jun 23 '13 at 6:50
  • @BalaSivakumar I saw the question when I searched and didn't look at it because it said "Google Chrome not playing mp4 files", I was able to play the files. The symptoms are different. More importantly, that's a low quality answer with the wrong flag name. Also there's no explanation about how to change the setting. Most people would have no idea what the "chrome flags" are and would have to search to find out what that means and how to actually fix the problem. If you'd rather not, then I'll create an answer so that there's a clear, full explanation of the solution. – codewaggle Jun 23 '13 at 7:08

The Solution was to Disable hardware-accelerated video decode in the Chrome experimental settings.

To do this you need to follow these steps:

  1. Enter "chrome://flags" in the address bar of the Chrome browser and press Enter.
  2. Find the setting named "Disable hardware-accelerated video decode.".
  3. Click the "Enable" link shown after the description of the setting.
  4. Restart the browser.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.