Today I started my computer and some errors showed up like this one, so some programs in autorun didn't started:

The application was unable to start correctly (0xc0000018). Click OK to close the application

I have this error when opening lot of programs, I can't even use 7zip. The only thing I did yesterday was to install a game through Steam and now I can't use like 70% of the software on my PC (most of them get this error on the entire program and some only on certain modules of it).

I just ran a SFC /scannnow and the result was: "Windows Resource Protection did not find any integrity violations".

Could this be some kind of a virus or Steam that messed up something? What should I do?

  • 2
    Its not a virus but your registry is still corrupt. I would use a restoration point to resolve this problem
    – Ramhound
    Jun 21, 2013 at 15:11
  • Unfortunately I disabled restoration points on my PC to preserve my SSD, so I can't do that
    – dan_s
    Jun 21, 2013 at 15:16
  • You can try to de-install the game, by steam you can install it back every time - maybe this helps? Jun 21, 2013 at 15:17
  • I could try but I think Steam will just delete some files, and not fix my registry problems.
    – dan_s
    Jun 21, 2013 at 15:22
  • 2
    @Daniele - Steam does not modify the registry. The installation of DirectX might. You also assume it was the Steam event and no some other event.
    – Ramhound
    Jun 21, 2013 at 15:30

4 Answers 4


I'm afraid very few people know the root cause of the mysterious 0xC0000018 EXE launch error because Microsoft makes it vague, even until Windows 10. When reading Jeffrey Richter's Programming Applications for MS Windows 4th-ed, I happened to find it out.

If a DLL requires to be loaded at a fixed address(in process virtual address space), but the requirement cannot be fulfilled, Windows asserts the very 0xC0000018 error. But there is no apparent clue to tell which DLL(s) cause the problem. A simple Google search of "0xC0000018" just pops you with lots of posts of baffled users.

To reproduce, you can prepare a solution(Visual Studio term) with one EXE and two DLL, and set both DLL to have linker option /FIXED /BASE:"0x44440000" and have the EXE implicitly load the two DLLs, then you will see 0xC0000018 error on EXE launch.

And yes, clearing out APPINIT_DLLS in the registry is your first bet to get rid of the possible culprits. Those DLLs (possibly from malware/spyware) will be loaded into every process you launch so may ruin your live.

I think Microsoft designed this DLL-force-loading facility for developing/debugging purposes, so for normal users, that APPINIT_DLLS should remain empty.

Then how to pinpoint the actual culprit DLL? Perhaps there is a way, use dumpbin.exe to check every DLL in APPINIT_DLLS or other possible auto-loaded DLLs(help with AutoRuns), check them one by one with dumpbin -headers. If there is no .reloc section, it is a fixed-location DLL.

  • 2
    A faster way is to use procmon. The last DLL the process was trying to load must be the one which triggered the error. Dec 25, 2015 at 1:49
  • 1
    A non-obvious way to trigger this error is when the executable has a very large data section (e.g. static arrays). If the section is large enough that it encroaches on some kernel dll's fixed address, c0000018 will occur if the executable is 32-bit. With 64-bit executables, Windows refuses to load them with 'bad image' error, which is quite confusing. Note that the error can appear and disappear with debug/release builds and appear unexpectedly after Windows updates change the address space layout of system dlls. Dec 23, 2018 at 19:19

Thanks for all suggestions, after some Googling I found this solution that actually looks like it worked for me:

  1. Press Win+R and type regedit
  2. Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\­Microsoft\WindowsNT\CurrentVersion\Windo­­ws
  3. Than search for APPINIT_DLLS and delete everything in it
  4. Reboot
  • Can you link to the site where you found info about this registry edit? What does it even do?
    – Karan
    Jun 22, 2013 at 2:39
  • Oddly I found this solution in a YouTube video... I don't know why it did messed up or why this solved my problem but it worked.
    – dan_s
    Jun 22, 2013 at 10:59
  • I'm having this same problem lately, and found this registry "fix" mentioned several places, but that key is already empty on my system.
    – Gordon
    Oct 16, 2015 at 0:23
  • 1
    My key was empty as well, and I was getting the error trying to run javaw / java sdk 8. Deleted the empty key, rebooted again, and it worked. Maybe it was the third reboot that did the trick, who knows.
    – Lee
    Jan 29, 2016 at 0:34
  • This doesn't work for Windows 7+ OS, because the APPINIT_DLLS mechanism is disabled by default.
    – KeyC0de
    Feb 18, 2017 at 1:17

I have installed about 40 games through Steam and don't have any problems, no, I don't think its a bad of Steam. Try to restore your system using Windows Restore Points: http://windows.microsoft.com/en-ph/windows-vista/system-restore-frequently-asked-questions

[EDITED] Maybe some DLL are missed, you can test the dependencies of the program you can't start using Dependency Walker: http://www.dependencywalker.com/

  • Like I said in the comment above I disabled restoration points on my PC to preserve my SSD, so I can't do that. I can't even serach for Restore in my PC because when I press the Windows button and I try to search something in the "Settings" tab then Metro just freeze.
    – dan_s
    Jun 21, 2013 at 15:20
  • Well, like I said above (if you like it this way), You can try to de-install the game, by steam you can install it back every time - maybe this helps? Jun 21, 2013 at 15:21
  • @Daniele - If your unable to even view the Start Screen its time to Refresh your Windows 8 installation. This will require the reinstallation of your desktop applications.
    – Ramhound
    Jun 21, 2013 at 15:31

May be this is associated with the following MS Update and McAfee Data Loss Prevention Endpoint (DLP Endpoint). It seems that there is a conflict between MS update and McAfee Data Loss Prevention Endpoint.

Visit the following websites please: Microsoft Patch MS15-038 on Windows 7 when Data Loss Prevention Endpoint is installed Microsoft Security Bulletin MS15-038 - Important

  • It will also affect explorer.exe and cmd. After windows start up, explorer associated programs will prompt: "Server Execution Failed". Jul 20, 2015 at 3:17
  • Maybe, but the OP did not mentions using McAfee and his post is 2 years old. He fixed his problem without your patch and your patch is a very recent one. In any case, please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Jul 20, 2015 at 9:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .