This happens with various games, from Battlefield 2 to Trackmania and therefore seems to be some network configuration error:

When anyone else hosts a LAN game I am the only one that can't see their server in the in-game server browser, nor can I join it with a direct IP connection. However, when I host the game everyone else is capable of joining my server without any problems. I am also the only one on the network experiencing these issues.

Things I already checked:

  • Windows Firewall is set to allow each application (and the problem still happens when it is completely disabled)
  • Other networking an internet programs like browsers, e-mail, ssh and ftp are working perfectly fine
  • Various static/dynamic IP address/subnet mask and default gateway settings don't fix the problem
  • 1
    What about your friends' firewalls? What's the LAN layout? Single router or multiple ones? Does it work on other networks?
    – gronostaj
    Jun 22, 2013 at 9:11

2 Answers 2


The problem seemed to be that the games don't properly handle my PC having multiple network adapters. They then connect using the wrong network adapter and only see that adapter's own network/subnet.

In my case this was caused by the Virtualbox network adapter, although it also seems to be common with other software adapters such as Hamachi. The simplest solution I could find was to disable the problematic adapter before playing any game. Other possible options are to disable all other network adapters except the one for your current network or to correctly setup the priority of your network adapters.

The priority of the network adapters can be set by following this procedure in Windows Vista/Seven (source):

  • Open 'Network and Sharing Center'
  • Choose 'Change adapter' settings
  • Hit ALT on your keyboard to show the menus
  • From the 'Advanced' menu choose 'Advanced Settings'
  • Under the 'Adapters and Bindings' tab select your proper network adapter from the 'Connections list'
  • Use the green arrow on the right to move it to the top of the Windows Network Adapter Priority List
  • Click 'OK' to apply the new settings and you are done!
  • Why is this crucial setting hidden like that? I'm using Windows 10 and your method works just the same. Thank you!
    – mattmilten
    Nov 12, 2015 at 7:07
  • I had to reboot after disabling all other network adapters, but this seems to have worked for me for StarCraft Brood War. Thanks! May 17, 2018 at 4:14
  • you've saved me a huge amount of time. In my case, disabling VMWare adapters on the connecting (non-host) computer did the trick.
    – pete
    Nov 29, 2020 at 3:05
  • Thanks man, I just spent countless hours trying to figure our why I cannot find any Local Area Network Games... Disabling VirtualBox Host-Only Network did it work for me Jun 15, 2022 at 21:45

If you know the server IP, you can enter via command line like this:

TmForever.exe /lan /join=

For me, it worked!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .