2

I have got kexec installed to do quick warm reboots without BIOS POST'ing and GRUB popping up. It will just reinit the kernel and do the bootprocess again.

Sometimes however, I like to do a full reboot, for example to change some BIOS settings or to start a different OS. I do this now by shutting down first.

Is there a command I can do in (Debian) Linux to ignore kexec and just do an oldskool full (warm) reboot including POST?

Needless to say, $ reboot is configured to use kexec. This all happens automatically when installing kexec.

5

Debian provides the script /sbin/coldreboot.

From the man page: "coldreboot is a script that forces a cold reboot regardless of whether kexec is enabled or not in /etc/default/kexec."

  • This is a nice one. Just as I found out I cannot kexec-less reboot anymore. They should make this default for the desktop GUI reboot option - IMO. – Redsandro Aug 30 '13 at 21:33
1

Here is instruction for Gentoo, but the same idea. Hope it will be useful:

Just stop the kexec daemon before rebooting. sudo /etc/init.d/kexec stop

  • Thank you. Quite simple, I hadn't found this instruction before. I've edited your answer to include the instruction – Redsandro Jun 23 '13 at 17:46
  • I just found out this doesn't seem to work (anymore) on recent Debian? – Redsandro Aug 30 '13 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.