I bought a new motherboard yesterday. Its a Gigabyte GA-X79-UP4 socket 2011.

Everything is great with this board except for one nagging issue I can't figure out. For some reason all of the drivers (downloaded from gigabyte's website) install fine except for the Realtek audio driver. No matter what I try it will not install.

I would call gigabyte but at this moment in time they are closed since they are PST and I am EST.

So... I am not sure what to do about the driver.

Things I have tried:

  • Running the installer as an Admin (Right-click run as admin)
  • Using the driver from the CD
  • Forcing Windows to check the folder for a usable driver.

It's late for me (been up all night) and I am beat so my idea stream is not flowing right now. What else could I try to fix this?

Any help is appreciated, I can tell you anything you need to know I am sitting in front of the computer.

UPDATE: The audio device is not defective! I booted up a linux live cd and the audio device works just fine. So this is strictly a Windows driver issue.

Uh... I could be doing something wrong with lspci, but according to this output there is no Realtek audio device in the system...


ubuntu@ubuntu:~$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation C600/X79 series chipset High Definition Audio Controller (rev 06)
02:00.1 Audio device: NVIDIA Corporation Device 0e0b (rev a1)
03:00.1 Audio device: NVIDIA Corporation High Definition Audio Controller (rev a1)
  • What version of Windows are you using?
    – gronostaj
    Jun 23, 2013 at 13:28
  • Windows 7 pro 64-bit Jun 23, 2013 at 13:28
  • What exactly happens when you try to install it? Any errors? Logs? Jun 23, 2013 at 14:45
  • No, that is the odd part. The installer finishes as if the driver install was successful. But the driver does not work and therefore get no sound. As far as errors go, the only thing I notice is the small yellow triangle next to the "High Definition Audio Device" that tells me there is a problem. Upon clicking on it there is a notice that the device could not start. Jun 23, 2013 at 15:21

3 Answers 3


I found the solution to the problem. There is a quirk in the board where enabling VT-d causes the audio device to not start in Windows. I disabled VT-d and the Realtek High Definition Audio Device has installed and recognized that I had headphones plugged into a jack.

I had stumbled across this forum post which solved the problem. Its a different board but I was able to reproduce the EXACT same problem. But since this is a desktop machine and not a server I will just leave VT-d disabled, I just need to leave VT enabled (hardware virtualization support)


Go to device manager, find everything audio-related, right click on those things and select uninstall. Then, try the installation again. That should work. The problem is that Windows installs generic drivers automatically and sometimes the installation program fails to overwrite these, even with admin rights.

  • no dice, tried install driver after removing, rebooted still no realtek. Jun 23, 2013 at 13:55

Try to update your windows , some drivers are installed in "optional updates".

  • Tried that, no driver is listed for audio devices. Jun 23, 2013 at 13:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.