I created a Virtual Machine in Windows Azure (Windows Server 2008).

Accesed using remote desktop connection and opened cmd.

Then tried to ping (which I can from my computer) but I got:

Pinging with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for

Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

I do have internet access, because I can navigate using iexplorer to google.com or facebook.com (examples)

Question: What is happening that I cant ping?

I tried this and it didnt work:


  • Can you ping other sites? – cutrightjm Jun 24 '13 at 1:45
  • Nope, tried google.com and it resolved the ip but got same result – sports Jun 24 '13 at 1:49

ICMP is not routed by Windows Azure's load balancer / firewall, according to this MSDN forum thread. I'm fairly sure this is correct, as I've seen other posts about this, and I just tried as well (producing the same time-out messages). Ping will work between instances in the same deployment, assuming you've enabled inbound ICMP.

Someone on the above-mentioned thread mentioned using Mark Russinovich's PsPing which supports tcp-based latency testing against a specific port. While it's not ICMP, it at least provides an alternative.

Also: If you create a VPN connection between Windows Azure and your on-premises network, ICMP should work fine over the VPN connection.


Voted +1 to @David-Makaogon's answer as ICMP is blocked by the Azure Firewall. Adding to the answer, you don't need any other utility, If one has Windows Server 2012 R2 running on the Azure. One can make use of Test-NetConnection cmdlet in Windows PowerShell.

A good read on using the cmdlet can be found -> here

Below is a quick demo of how I ran it on a VM :

[dexter.cloudapp.net]: PS C:\> Test-NetConnection -ComputerName google.com -Port 80                   

WARNING: Ping to google.com failed -- Status: TimedOut

ComputerName : google.com
RemoteAddress :
RemotePort : 80
InterfaceAlias : Ethernet 17
SourceAddress :
PingSucceeded : False
PingReplyDetails (RTT) : 0 ms
TcpTestSucceeded : True

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.