1

I installed the Windows Application Compatibility Toolkit and installed SQL server 2012 express to use as the database server. When I run ACT and try to create or select a database, it puts a little red warning sign and says that 'This database is not compatible with this application'

How do I solve this? both my user account and local admin account have full permissions to this database

1

Per the system requirements for ACT 6.5, you must use SQLServer 2005/2008 or their express editions.

http://technet.microsoft.com/en-us/library/cc721860%28v=ws.10%29.aspx

uninstall 2012 and install sqlserver 2008 express. then attach your databases to it.

| improve this answer | |
1

You could try to change the Compatibility Level of the database to 100 (for SQL Server 2008/R2 default) that may support ACT. Changing compatibility only gives you partial backward compatibility though, but it should work for majority of the times.

To change the compatibility level, go to the properties of the database and then "Options"

| improve this answer | |
0

You could try to change the Compatibility Level of the database to 100 (for SQL Server 2008/R2 default) that may support ACT. Changing compatibility only gives you partial backward compatibility though, but it should work for majority of the times.

To change the compatibility level, go to the properties of the database and then "Options"

| improve this answer | |
0

This occurs because SQL2012 doesn't any longer fully support the DATABASEPROPERTY function.

ACT uses it to check whether the database is ready for use, but the properties IsDetached and IsNotRecovered return null instead of zero in SQL2012.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.