3

I have a dev folder in my www folder, and when I tried to copy it over to production, for some reason it seems I made a mistake and the content of the root-level dev folder got copied over. I delete the live folder and replaced it with a back up I had.

I'm still connected via Putty, but restarting httpd doesnt work (source path '/dev/urandom' does not exist)

I can't connect to it again however, and I can't even transfer a database / file backup I've just made to another server.

On that picture you can see what I have left in the dev folder. The pic on the right is my other server, just used it for comparing. http://screencast.com/t/I4XqjwR0

What would you do?

migrated from stackoverflow.com Jun 24 '13 at 8:43

This question came from our site for professional and enthusiast programmers.

  • 1
    Off topic. Try on a linux stack. – user2246674 Jun 24 '13 at 7:21
  • Just as a side note: This nicely illustrates why you should not in general work as root, not even when deploying new code to your website. – sleske Jun 24 '13 at 8:44
6

That might help

cd /dev
./MAKEDEV std
  • I'm getting -bash: ./MAKEDEV: No such file or directory [root@server dev]# ./MAKEDEV std – Dany P Jun 24 '13 at 7:29
  • But I see it at ./sbin/MAKEDEV – Dany P Jun 24 '13 at 7:30
  • i cp'ed to ../dev and then executed your command. Worked. THANKS A BUNCH MAN I FEEL SO HAPPY NOW YOU HAVE NO IDEA. By chance you're not in this room I'd turn gay – Dany P Jun 24 '13 at 7:32
  • Then a mere /sbin/MAKEDEV std or even just MAKEDEV std should have helped; no need to copy it over. – glglgl Jun 24 '13 at 7:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy