It's been a long day and I am pretty tired and that's the only reason I can figure that I thought I would rename one of the volumes on this old macbook (running osx 10.6) without worrying about anything else. Actually, it's the /home partition and I inherited the computer from my wife and it's always bothered me that there's a space in the name of the volume: "Bubbles Home".

Well, I renamed it and can login no more. No admin user or other users enabled. No working disk drive. Pretty stupid.

Here are the tools I have at my disposal: a working Linux install on a USB stick. I can boot linux, mount the root and home partitions and write to them (so worst case scenario: I can grab all the files), but as far as repairing the situation goes, I am stuck. What do I edit?

I tried mounting root and changing /Volumes/Bubbles back to its former name with the space but that didn't help (I noticed the root partition was listed as a symbolic link in there but the home partition was listed as a directory). I also looked for /etc/fstab, but there is only an empty file called fstab.hd.

All the googling I've done has uncovered how to fix this from within osx and mostly using GUI tools so I'm a bit lost how to fix from within Linux.

EDIT: I can't login via safe mode because there is only one username enabled it can't find the information necessary to log me in. If I had a better understanding of OSX directory structure, I think I could recreate the proper symbolic link and get it working again. Maybe someone with osx who has their /home mounted on a separate partition ("Volume") could tell me what the following commands look like on their machine:

ls -l /Volumes/
ls -l /Users/
ls -l /home/

I think I need to re-create the symbolic link in /Volumes but I am not sure if it should point to /Users (and if there should be one in /Users) or if it should point to /home/.

Thanks for any suggestions anyone can be provide.

2 Answers 2


Instead of booting from Linux, I would start by booting into safe mode. You do this by holding down the Shift key immediately when you start the Mac, and keep holding it until you see the gray Apple logo on the screen.

If this works, you can run DiskUtility once it's fully started in Safe mode. Hopefully DiskUtility should help you fix the disk problem. There's more information at this apple support document


This is not exactly a solution, but it's closer than mounting the partition within Linux and then scrabbling all the files I cared about off the drive. After a day of messing around and editing fstab with various configurations and symlinking all over the place, after a day of hacking and googling, in short, I discovered a great hack.

First, I started by booting my Linux thumb drive and then mounting the OSX Root partition (for me it was /dev/sda2):

sudo mount -type hfs -o force,rw /dev/sda2 /mnt/osx_root

Then, I read somewhere, that you can remove the file .applesetupdone (full command below) in order to trick OSX into thinking that it needs to finalize set-up and it will run you through the process of creating a new admin account when it boots again.

Here's the location and command to remove the setup file:

sudo rm /var/db/.applesetupdone

After that, I booted into OSX and created a new user (with admin privileges!) and set-up that user's home to be a symbolic link to my old home partition. (It is possible that OSX was only able to auto-mount that partition because I had told it to in the custom fstab that I wrote, but I am not sure.)

This is pretty messy but it works and I've got a clean user. I was also amazed that you can get whatever files you want this way from a computer you don't have a password for (assuming the home partition is not encrypted).

After that, I tried resetting the broken user's home directory, but I wasn't holding my breath that this would work and I was perfectly satisfied with a new working user with access to all of the broken user's files and a mounted partition.

I have no idea if this will help anyone else (probably not), but I'm posting it for posterity.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.