I'm attempting to use Windows Virtual PC to set up a Windows 98 (SE) VM; you know, for nostalgia's sake. However, whenever I run it, I get the following error:

An internal stack overflow has caused this session to be halted. Change the STACKS setting in your CONFIG.SYS file, and then try again.

"An internal stack overflow has caused this session to be halted. Change the STACKS setting in your CONFIG.SYS file, and then try again."

It doesn't seem to matter what I do. I've run it in Safe Mode, used two different Win98SE ISOs, and it happens whether or not I execute any commands. I don't appear to have access to the CONFIG.SYS file (it's not in the Virtual PC directory or the VM's direcory, it's not in the settings, and I can't run the machine long enough to configure anything).

To be clear, this is the first boot from the ISO in an attempt to install the OS. I've been following instructions online akin to:

  1. Open the VM directory, use "Create a virtual machine".
  2. Give the VM 64MB or 128MB of RAM.
  3. Open the settings for that VM, and change the DVD Drive setting to the Win98SE ISO location.
  4. Run the VM.

Then, after a random (but short) duration of time, it beeps at me and sends me this message, and I have no choice but to turn off the VM.

I'm running Windows 7 x64 with 12GM RAM on an Alienware M18x r2. I've searched around, but everyone who seems to have had this problem before has had access to CONFIG.SYS. I do not appear to.

How can I bypass or resolve this error? (Is there another virtualization software I should use?)

  • What size did you specify for the virtual disk? – Ƭᴇcʜιᴇ007 Jun 25 '13 at 17:22
  • @techie007 I don't recall having to specify a size for it. I think that's part of the OS installation (fdisk, isn't it?) that I can't even manage to get to. If I go to the VM settings, it says the current size is 256kB and the total disk size is over 130,000kB. – Eric Jun 25 '13 at 17:29
  • This is just anecdotal evidence but I have successfully installed Windows 98 in to the free version of VMWare several times. So if you can't solve your problem, try that. – Scott Chamberlain Jun 25 '13 at 17:31
  • @ScottChamberlain Via ISO or boot disk? If it's the former, I'll definitely keep it in mind. – Eric Jun 25 '13 at 17:37
  • I created a ISO from a physical CD I had. – Scott Chamberlain Jun 25 '13 at 17:40
up vote 4 down vote accepted

Windows Virtual PC doesn't officially support Windows 98. Use an alternate VM such as VirtualBox or similar instead.

  • Interesting that I've heard of others getting it working, though. Will try VirtualBox and/or VMWare and we'll see how it goes. – Eric Jun 25 '13 at 20:57

I was trying to install DOS 6.22 in a Virtual PC and was getting this problem. I fixed it by adding the below lines to CONFIG.SYS, though I haven't fully tested the solution yet. Just wanted to post this here because it came up when I was googling the problem.


I changed the disk from dynamic to fixed disk, then created with fdisk the new drive. Then i rebooted, 'del' for bios, changed to boot from CD/DVD (.iso). Then formated C: and it worked.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.