I have some wmv files which use the G2M4 codec. They were created by go to meeting. Only windows media player can play these files. I want to remove this codec (is that even possible?) or convert it to a form that can be played by regular media players on computers and android phones.

How do I do it ? I googled and tried the "batch file" approach and transcoder approach. Both of them did not work. Also, any video converter free can only convert part of the file and it looks like no FULLY free video converter can do this job. So, I am stuck and I need your help to figure this out.

http://glenndcitrix.wordpress.com/2012/02/10/3-ways-to-remove-the-gotomeeting-codec-from-your-recording/ http://academe.co.uk/2012/01/convert-gotomeeting-video-files-to-another-format/

1 Answer 1


I use this batch file code all the time (daily and multiple times a day). I drag and drop the GoToMeeting Video file onto this batch file and then enter the version number.

@echo off
if "%ProgramFiles(x86)%XXX"=="XXX" (
set "ProgRoot=%ProgramFiles%"
) else (
set "ProgRoot=%ProgramFiles(x86)%"
echo ***************************************
echo * To determine the GoToMeeting build, *
echo * Right-click on the GoToMeeting icon *
echo * in the system tray and select About *
echo ***************************************
SET /P build=Enter the GoToMeeting build number (Example: 457, 723, 799, etc):
"%ProgRoot%\Citrix\GoToMeeting\%build%\g2mtranscoder.exe" source=%~1

In my case, my version number is 1082.

enter image description here

This will launch the G2MTranscoder that will strip the GoToMeeting Codec from my recorded file. From here I can then use ffmpeg to transcode my video file.

  • I am confused. I have two builds , ie two folders 1133 and 1172 in C:\Program Files (x86)\Citrix\GoToMeeting. I went to both and could not find an exe file which would show me the above UI/screen. But, I saw the properties of the exe files and they showed version 5.7 and build 1133 and 1172 respectively. Jun 25, 2013 at 18:23
  • I ran the batch file above and entered 1172. Nothing seems to have happened. I already have a wmv file and I want to strip the irritating g2m4 codec off it. Jun 25, 2013 at 18:26
  • That's strange since the latest version that I have is 1082. You may want to try downloading and reinstalling GoToMeeting. Uninstall the current versions first. Also note, you can transcode the video with different versions of the transcoder. It does not have to be the original one the video was recorded in. Worst case, set the path manually in the BAT file.
    – kobaltz
    Jun 25, 2013 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.