I SSH with PuTTY from my Win7 x64 laptop to a Unix environment for my office. The problem I'm facing is very similar to this post where I cannot send an Esc character to the terminal. I first noticed it when trying to exit insert mode in vi, but based on the troubleshooting within that post that I've done it seems that hitting the Esc key just isn't doing anything at all.

So first off, let me restate the problem. Logged into PuTTY, vi a file, go into insert mode, can't come out without hitting F1 and then :q (to quit the help), then I can save and quit the document.

The first troubleshooting step in the other question states to try this:

 python -c "print ord(raw_input('char '))"

Then the result should be 27. Running this, I'm told I have an empty string (similar to one of the comments, but this user never comes back).

Then I tried the next thing in the comment...but to be honest I had no clue what I was looking for. Command and my results are given:

# bind -p | grep -i '\\e' | less

"\e\C-g": abort
"\eOD": backward-char
"\e[D": backward-char
"\e\C-h": backward-kill-word
"\e\C-?": backward-kill-word
"\e[1;5D": backward-word
"\e[5D": backward-word
"\eb": backward-word
"\e": end-of-history
"\e[6~": end-of-history
"\eOF": end-of-line
"\e[4~": end-of-line
"\e[8~": end-of-line
"\e[F": end-of-line
"\eOC": forward-char
"\e[C": forward-char
"\e[1;5C": forward-word
"\e[5C": forward-word
"\ef": forward-word
"\eg": glob-complete-word
"\e^": history-expand-line
"\e#": insert-comment
"\e*": insert-completions
"\e.": insert-last-argument
"\e_": insert-last-argument
"\ed": kill-word
"\eOB": next-history
"\e[B": next-history
"\en": non-incremental-forward-search-history
"\ep": non-incremental-reverse-search-history
"\e=": possible-completions
"\e?": possible-completions
"\eOA": previous-history
"\e[A": previous-history
"\e[2~": quoted-insert
"\e\C-r": revert-line
"\er": revert-line
"\e ": set-mark
"\e\C-e": shell-expand-line
"\e&": tilde-expand
"\et": transpose-words
"\eu": upcase-word
"\e.": yank-last-arg
"\e_": yank-last-arg
"\e\C-y": yank-nth-arg
"\ey": yank-pop

Using the Ctrl+V then hitting Esc does nothing until I hit Enter, which then displays ^M (I believe this is the carriage return (CR) character that I get from quoting the Enter key). Typing Ctrl+[ will let me exit vi, so I'm assuming that's the correct character I'm looking for, I just don't know why my terminal seems to think Esc is not bound or is bound to some random character.

My current settings for the keyboard/terminal function keys and keyboard are set to "Esc[n~". I've tried changing them to "Linux" and "Xterm R6", but this doesn't seem to change anything.

I've recently had to add a tunnel for another application to work, and changed the setting under Terminal > Features > Disable application keypad mode set to true. I've since reverted to this being false, but that does seem to resolve my problem either.

My assumption is in saving my profile after these changes I accidentally changed something else that is now saved, but reverting to the default settings and logging into my server does not resolve the issue either.

I have no ~/.vimrc and no changes were made to the server according to management so I'm guess I did something.

My question at this point is: What else can I check in PuTTY or try changing that will alter the behavior of how a key is being passed to the prompt? Is it possible to just create a .vimrc to force this to work? What else can I do to make this work?

I'm a new user to these forums so if I made a mistake in laying this out please let me know, but any help in troubleshooting my issue or helping to point me in the right direction would be lovely.

  • Just to clarify, when you run the python command you should then press Esc.
    – terdon
    Jun 26, 2013 at 23:02
  • Correct, when I press Esc. Nothing will happen. I press Enter, then it says i have an empty string. Jun 27, 2013 at 14:11

4 Answers 4


I just started having the same problem, hitting Ctrl+[ also exits insert mode in Vi (it's an alternate key for Esc).

To fix it for me, I went to Terminal > Keyboard, and changed the Function Keys and Keypad to VT100+ emulation.


...so again getting frustrated with vi numpad not working, I changed the "Disable application keypad mode" as mentioned in my original question back to "True/checked". This not only allowed me to use my numpad in vi again, but seems to have repaired my Esc issue as well.

The only think I can add is that it seems my machine also had a java error of some kind that seemed to mess up Windows updates that was fixed by one of our IT Techs. Perhaps the two unknowingly correlated?? At any rate, I am closing the question.

Perhaps I didn't save my profile correctly? I'm pretty sure I double-checked this, but I'm also struggling with the idea this "magically fixed itself".


Glad that you found an answer, which was mucking with PuTTY settings. As an alternative, if the Esc key doesn't work as expected, you can often try Ctrl-[. ][CyberPillar][: ctrl key keyboard sequences mentions this, as does ][CyberPIllar][: Meta key. Keep that in mind, as the tip can occasionally be quite handy, perhaps e specially if you regularly use the Esc key with remote Unix programs (like vi, as you mentioned).

  • 1
    Hi TOOGAM, I've noticed that nearly every answer you've contributed to stack exchange has a link back to your personal website. While we certainly appreciate relevant contributions, you should be careful to A) ensure that you disclose your affiliation with CyberPillar, and B) ensure that you don't over-publicize your site Jan 6, 2015 at 2:35
  • 1
    The site is non-commercial; to date I've not set up any advertising on it, nor sold anything on it. The site's entire focus has been pure info sharing. I'm also not using Stack Exchange to try to generate a bunch of pointless traffic. If anyone checks, you should find that every hyperlink has info that is quite related to the topic, and generally more info than just what was in any answer I made on StackExchange.
    – TOOGAM
    Jan 6, 2015 at 12:02
  • Then I will politely suggest that you stop hyperlinking to your site. Your behavior thus far is very inconsistent with your claims of no SEO Jan 6, 2015 at 13:01
  • @MikePennington The link you provided refers to promoting one's own product, and stating affiliation with the product. However, TOOGAM's site has a clearly stated informational purpose. In addition, he states that the site prefers free options to commercial. His statement about having no ads is completely true. It seems that he simply has a large database of knowledge that is useful on Super User. Feb 24, 2015 at 16:44

maybe I have a different shell or something but ctrl+alt+[ does it for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .