Recently Norton Internet security deleted ml.exe (an assembler I use to program in masm32) off of my computer, thinking that one of the programs I had written with it was a virus (it was most certainly not). Fortunately, I had a copy of ml.exe backed up in an external hard drive, and tried to copy it over to my computer. The old ml.exe was located in C:\masm32\bin, so I tried to copy the new one to that location.

After disabling Norton (which had opened the folder and preventing me from accessing it), I am still unable to copy the new file to C:\masm32\bin. When I tried, Windows announced that I would need Administrator permission to copy the file. Since I'm an admin, I figured this wouldn't be a problem although it was unexpected, as I have never had to provide administrator permission to access this folder before.

However, instead of prompting me to enter my password, Windows simply refuses to copy the file:

Never seen this one before

I repeat, I was not asked to provide a password. It simply says that I do not have permission.

Does anyone know what's happening and how to fix it? Is Norton still causing problems, or it something else?

  • Unless you are using a non admin account, the UAC does not ask for a password when doing an action that requires elevation, it simply asks if you want to do that without prompting for a user account and password.
    – Davidw
    Jun 28 '13 at 1:05
  • @Davidw The account is admin, and come to think of it you're right, I normally don't have to provide my password from this account; it just surprised me that the operation failed and I thought that might have something to do with it. Jun 28 '13 at 1:10

Add the file path (the destination, C:\masm32\bin\ml.exe?) to an exception for your antivirus software. This will probably give you permission to copy the file to that location again.

I think Norton calls them Exclusions. Look for that in the Settings window. (Rebooting / relogging after you do so might help)

  • I ended up adding the entire masm32 directory as ml.exe generates other files during assembly that Norton kept deleting, but this worked out. thanks! Jun 28 '13 at 5:31
  • 2
    That is strange, since your initial failure to copy was "After disabling Norton". It looks as if 'disabling' is not really 'disabling'.
    – Jan Doggen
    Jun 28 '13 at 8:46
  • 2
    @JanDoggen That's true, somehow - I'm not sure how - virus scanners are able to lock down a path when they think it's infected and have it remain this way even when you kill all the processes and services. I'd like to have someone explain me how that works, but that's another question for another day I guess :) Jul 5 '13 at 22:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.