4

Apparently, there's a command:

netsh int ip reset

which resets TCP/IP settings for Windows XP/Vista/7, but I'm not sure that it works correctly on Windows 8.

cmd screenshot

When I typed the command under command prompt (Admin) I got two errors as pointed out in the screenshot:

Resetting , failed.  
Access is denied.

At the end it said Resetting , OK!, so how do I confirm if it worked or not?

2
  • Just double checking, are you sure you were in an elevated command prompt?
    – Keltari
    Jun 28 '13 at 3:42
  • @Keltari: Yes, you can also notice that on the title bar of command prompt in the screenshot where it says "Administrator: Command Prompt".
    – cpx
    Jun 28 '13 at 4:18
3

run ProcMon in background while runing the command and filter for Access Denied errors in the Result column.

2
  • 1
    When I ran this it stated that it was HKLM\System\CurrentControlSet\Control\Nsi\{eb004a00-9b1a-11d4-9123-0050047759bc}\26 that netsh was getting access denied on. Added permissions to this reg key, and it worked.
    – uNople
    Sep 2 '13 at 23:35
  • 1
    nice to hear that it worked. Sep 3 '13 at 3:59
0

I've run this command on a lot of customers' PCs, and despite the error message, the command has always done its job. Unfortunately, I don't know enough about the command to say why it produces an error message.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.