So, I have a macbook pro 15" and tried to install windows 7 on it using boot camp, the instalation succeded and windows 7 loaded the first time fine, i've then installed the apple drivers on it and on the boot camp assistant i've set windows partition as my primary OS, then, I've tried to reboot so the changes would take effect, and since then nothing works anymore...

Basically, the macbook won't boot from the Windows nor the OS X partition, in fact, it doesn't even load the startup manager anymore, it doesn't even show the apple logo when booting, when I hit the power button, It immediately shows a grey screen with a thunderbold and firewire symbol and doesn't load anything.

Trying to boot holding "Option" makes it try to boot from windows, but it crashes during the loading of the OS, holding Cmd + R it shows a group of advanced startup options (however, they are windows OS options, the recovery HD of the OS X doesn't load this way), but none of them solves the problem, it crashes even when trying to repair the initialization files.

I tried to boot it from the OS X instalation dvd, and also with a windows repair disk, and it's not possible, it doesn't allow me to boot from any CD/DVD actually, holding down "C" doesn't do anything, and every help thread I've read everybody says to just hold down Cmd+R, Option or C, and the startup manager should help, problem is: the startup manager doesn't even load in the first place and none of these commands help

I'm starting to get really desperate, as I only have a windows desktop besides the macbook, I was thinking maybe I could connect the macbook HD on my desktop, boot it using a Chamaleon boot disk and then use the OS X installation DVD to format and reinstall the OS on the macbook HD.

If anyone can help me with this I would very much apreciate it. English is not my native language, sorry for any gramatical error I've made

  • Try using booting up a gparted live disc and then use it to make sure he partitions are all set properly. – user88311 Jun 28 '13 at 18:11
  • I've downloaded and burned the gparted .iso, but I still can't make it boot from the cd, I'm pretty sure I would be able to fix it if I could somehow force a cd boot, I might them be able to repair one of the OSs or at least forma and reinstall it, but it doesn't respond to the OS X boot commands and never prompt to choose boot from the CD... – Veika Jun 29 '13 at 2:44

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.