Whenever my Raspberry Pi is connected to the network (via ethernet) the entire network is slowed to a crawl. On my main computer, ping times for google.com go from ~10ms to ~200ms and it takes forever to load web pages. Connections are also slow on the Pi, with an apt-get update showing pathetic speeds in the order of 1KB/s. Turning off the Pi completely removes the drag from the network. Interestingly, the local network appears to be fine, with scp copying files at reasonable rates; around 4.5MB/s to the Pi.

I've tried static and dynamic IP addresses for the Pi, but both have the same problems. Switching from Raspbian to Arch also had no effect.

I've checked the connection's duplex with dmesg | grep -i duplex, which shows that the Pi's connection is running at 100Mbps, full-duplex, as expected.

My modem/router is a Billion 7404VNPX (an Australian thing); relatively high-end, albeit a bit buggy at times (it will occasionally delete all its firewall settings). It assigns IPs in the range to and has as its own IP. When I assign static IPs I tend to use the area. I recently tested the connection with the Pi plugged straight into the modem (rather than via a wall socket) and it managed to crash it entirely!

I am starting to suspect that my modem isn't as reliable as I previously thought, so I'll try and get onto someone else's wired network in the next few days.

  • It sounds like the network device on the Raspberry Pi is to blame. Are you connecting to your connection through the Wireless or Lan adapter?
    – Ramhound
    Jun 30 '13 at 8:20
  • If the Pi slows WAN traffic but not LAN traffic, then the Pi is almost certainly doing something to the WAN, not the LAN. Jul 5 '13 at 7:08
  • @david My thinking exactly, it must be doing something to the WAN, although I can't work out what, and it seems to be OS independent. I'm using the ethernet port on the pi at the moment, but I have a USB wifi adapter that I'll try out... (I suspect this will fix it, although it's less than ideal) Jul 5 '13 at 11:03

You talk about it slowing the entire network and then just reference a ping to Google. There is a big difference between LAN and WAN. Assuming you are just having slowness over your WAN to external sites, have you ruled out that the Pi is downloading anything? It tends to download updates/install packages on a fresh install of many applications.

  • Interesting, I just tried a file transfer from my desktop to the Pi and it averaged around 4.5MB/s, which isn't too shabby considering the 100mbit connection and the slow SD card. However I don't think the Pi is up to anything; netstat just shows the ssh connection and some ntp time stuff. I disabled ntp in case it was pestering the time server or something silly, but it made no difference. Jun 30 '13 at 11:59

It's possible that there might be interference from the Pi.

I solved this problem by moving the Pi away from my WiFi router (using a 2 meter patch cable instead of the 0.5m I was using). Both the model A and model B+ caused the slowdown.

Maybe the culprit in my case was the wireless kbd/mouse dongle.


Try using a crossover cable and connect it directly to your computer using static IP - If the scp is still slow, it's either a configuration problem or the network adapter on the PI is faulty.

  • Do you reckon 4.5MB/s is too slow for writing to an SD card? I thought that seemed kind of ok Jun 30 '13 at 12:54
  • What class is the SD card? I always use class 10 Jun 30 '13 at 17:44
  • I just tried it with a crossover cable and got 4.5MB/s again. The card is class 4 though, and dd'ing zeros runs at about 7MB/s Jun 30 '13 at 23:35
  • The class is more or less equal to MB per sec. 1 for 1mb/s etc. sounds about right for a C4. A C10 is about 9.5mb/s for me. Jul 1 '13 at 21:50

I'm seeing the same problem I think. Internet (WAN) access from desktop PC slows right down to a crawl some time after I boot up my new Raspberry Pi. No sign of much network activity on the Pi or my desktop PC, but it's very slow. Kilobits per second instead of megabits. No sign of any errors in syslogs on either machine, no sign of error messages on BT homehub router event log. Broadband speed check page is so slow to load I almost cannot run the test .. but managed once, to get 0.5Mbit/s (normally 10Mbit/s). SMPT and IMAP server connections time out too. I've unplugged the Pi from the router and internet access is still slow several minutes later. In the end, I restarted my router, and things are back to normal. Not a satisfactory answer though!

  • 1
    If you think that the answer is not satisfactory, what is your motivation to post it? Nov 25 '15 at 11:40
  • My motivation was to highlight that (a) the problem still exists, (b) earlier discussions seemed to be side-tracked onto LAN questions, (c) my testing suggests that the router is somehow being upset such that the WAN connection suffers.
    – Andrew
    Nov 25 '15 at 14:44
  • Enquiries elsewhere have elicited suggestions to look at problems with signal-to-noise ratio on the WAN connection caused by common mode noise induced by the Pi's PSU, or memory leaks in the router induced by some strange DHCP or dynamic DNS behaviour.
    – Andrew
    Nov 25 '15 at 14:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.