27

Whenever I go fullscreen in html5 things it puts a message at the top saying you're now in fullscreen, the problem is that this message totally stops you being able to do anything else until it disapears. So if I open a youtube video in fullscreen I can't pause it or do anything until I wait for the message to disapear. How can I disable the message totally?

  • 1
    For Firefox version 43 onward the options are changed (refer to my comment below) – Amit Verma Dec 16 '15 at 19:04
43

This is the security feature, but yes it's annoying if you're on trusted site and the message popups every time you enter full screen.

Solution: enter about:config in address-bar, and search for full-screen-api.approval-required and set it to false

You're done!

| improve this answer | |
  • 8
    Removed the annoying warning without so much as a restart. @Lost you may want to accept this answer. – Lilienthal Nov 10 '13 at 23:57
  • 5
    It would appear that the OP's username has become prophecy. – Coldblackice May 14 '15 at 2:55
  • I think this feature is very annoying, so I disabled it, thanks for the tip – Sergio Abreu Oct 12 '15 at 2:40
  • 1
    full-screen-api.approval-required preference no longer exists. – user598527 Aug 22 '17 at 8:19
  • Sorry for accepting the answer late. It only took me 4 years 7 months. – Levi H May 17 '18 at 11:22
12

UPDATE: OCT-2019 to cover Firefox Quantum:

Enter about:config in Firefox address-bar and search for the keyword "full-screen". Identify following listing and change their respective values as mentioned against them below:

full-screen-api.transition-duration.enter - 0 0
full-screen-api.transition-duration.leave - 0 0
full-screen-api.transition.timeout - 0
full-screen-api.warning.delay - 0
full-screen-api.warning.timeout - 0

(Archival Notes) FireFox 42

Option "full-screen-api.approval-required", no longer hides the Website is Now Full Screen warning. In previous versions setting it to "false" could resolve the problem. They are putting a new option in i.e. (full-screen-api.warning.timeout "0") that will do the same thing, but it will be rolled out in FireFox 43.

You can change the fade in/out animation when going full-screen by setting:

full-screen-api.transition-duration.enter 0 0

full-screen-api.transition-duration.leave 0 0

Note/Warning - Defaults are 200 200 and 0 0 will remove them completely.

Keep in mind these are put in because they are a security features to help stop Phishing Attacks. So either wait till Firefox should enable "full-screen-api.warning.timeout" option in next few releases OR use above at your own risk...

| improve this answer | |
  • More information > support.mozilla.org – tahwos Nov 28 '15 at 17:32
  • Another link > support.mozilla.org – tahwos Nov 28 '15 at 17:34
  • Creating a userChrome.css file, was the only method that worked for me - all others failed. – tahwos Nov 28 '15 at 17:49
  • 2
    I'm getting tired to track these kind of config changes… they happen more and more often. – Gras Double Dec 13 '15 at 11:32
  • 5
    Firefox 43 is Out and setting "full-screen-api.warning.timeout" to 0 (ZERO) is working well.. Try it out!!! – Amit Verma Dec 16 '15 at 19:03
0

Since Firefox 43 (still working in 59)

1) enter about:config in address-bar
2) set full-screen-api.warning.timeout to 0

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.