I have two working network connections: One connection is for a wired ethernet card adapter and the other is for a wireless usb adapter.

Both connections work fine when used separately, but when both are enabled, the wireless connection doesn't work.

  • The wired connection obtains its IP address via DHCP through gateway - The DHCP range for this router is -

  • The wireless connection obtains its IP address via DHCP through gateway - The DHCP range for this router (Android phone acting as wireless hotspot) is - 192.168.6.XXX with 8 allowed connections. (I'm also having trouble figuring out how to determine which IP addresses are reserved for DHCP when using this hotspot - here's another question I posted about this problem)

If both connections are enabled, the computer will have two separate IP addresses. For example, the wired connection will be assigned and the wireless connection will be assigned

There isn't a direct conflict of IP address obviously, but I can't get internet access until I disable the wired connection.

Does anyone know what the problem is here and how I can fix it without having to disable and enable the wired connection every time I need to switch between the two adapters?

  • Could it be some sort of security software like a firewall? What exactly happens when it “doesn’t work”? Can you ping? Do all protocols fail (FTP, P2P, NTP, etc.) or is it just browsing (HTTP)? Can you check your email? Have you tested to see if specifying the connection to use works?
    – Synetech
    Jul 1, 2013 at 18:51
  • Could you add your routing table? (route print). Also, can you describe more about what you're doing and why you need both connections?
    – Aquadisco
    Aug 3, 2014 at 0:13

2 Answers 2


There is no easier way to do what your asking. You can be connected to both wired and wireless connections, but will only be able to get internet through one. The way you would do that is to define a static IP on the connection you want to use. This is essentially just enabling and disabling an adapter as you have been. In short, your computer needs to know exactly where it is getting internet from, if you define two sources it will either not work or prioritize a wired connection as it supports higher bandwidth.

Just give it some thought, what would having internet via wireless AND wired connections mean? You have TWO internets? You just have internet? I think the latter prevails

  • I understand, but I've had this setup in other situations where, as you said, one connection was given priority over another. In this case, my wired connection - although connected to the router - is not connected to the internet. They should have written some better logic in whatever code is executed that tells the computer which network adapter to use for internet access!
    – user234831
    Jul 1, 2013 at 14:13
  • The reason it works the way it does is because if you have a wired connection it takes priority, end of story. Its faster. If you then lose connection via wired, it won't automatically toggle to your wireless connection because it leaves you no indication that you lost wired connection, and it assumes a lot by thinking you then want to go to a wireless connection. You could add an option sure, but then what if no wireless connection exists? The logic itself would be boilerplate. Also this could be your wireless USB adapter drivers that force this behavior further Jul 1, 2013 at 14:26
  • @user234831 the question is old though, I just wanted to note that Jason's point about impossibility of getting Internet though both interfaces at the same time is wrong. You just have to configure routing table, there's in particular a command for kernel to balance the Internet between the ISPs. There're articles about it, see e.g. this one.
    – Hi-Angel
    May 12, 2016 at 7:59

I'm not sure what version of Windows you are using, but this may help:

  1. start ncpa.cpl or View network connections from the Start/Windows button.
  2. ALT-N S for Advanced->Advanced Settings...
  3. Under Adapters and Bindings should be Connections, which lists the connections Windows will try to use and in what order. You can try to change the preference order there.

If that doesn't work, then it's as @Jason Bristol says; whichever connection got an address last will have preference in Windows' single-instance routing table.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.