I have Cygwin installed on Windows 7 in a windows domain sign-on environment. I can run most typical commands without issue, but I cannot for the life of me use the "mv" command to move or rename files, regardless of the file or directory.

I can copy and create files without issue.

└──> tmp $ >> pwd
└──> tmp $ >> touch test.txt
└──> tmp $ >> mv test.txt hello
-bash: /usr/bin/mv: Permission denied

I have already tried running Cygwin terminal as Administrator and the problem is the same.

I'm open to workarounds, such as trying another exe for moving files and redirecting the mv command to it. Moving files works in the Windows Command Prompt.

UPDATE: It appears that there may be a security restriction on my laptop that either prevents accessing/copying/executing the "mv.exe" program by its name or by its heuristics. Still willing to accept workarounds that replace the mv command as mentioned above.

UPDATE 2: Screenshots in windows command line and when I open mv.exe in Windows.

windows command prompt

enter image description here

UPDATE 3: output of file command:

└──> ~ $ >> file /usr/bin/mv
/usr/bin/mv: writable, executable, regular file, no read permission
└──> ~ $ >> chmod 777 /usr/bin/mv
chmod: changing permissions of `/usr/bin/mv': Permission denied
└──> ~ $ >> mv
-bash: /usr/bin/mv: Permission denied
└──> ~ $ >>

ldd also reports permission denied.

  • try changing the file permissions Mv.exe,see this article:uwec.edu/Help/drives/permissions.htm – stderr Jul 8 '13 at 19:32
  • Does this also happen in the Windows command prompt (cmd) ? – harrymc Jul 8 '13 at 19:58
  • It's worth checking that the permissions on c:\cygwin\bin\mv.exe, in both Windows and Cygwin, permit execution for the accounts you're using. Also, see what happens when you double-click that executable in Windows Explorer -- if you see a UAC prompt, then that's why you're getting the error in Cygwin, and it will occur regardless of permissions; I do not know a way of working around that except to disable UAC entirely, which is rarely desirable. – Aaron Miller Jul 8 '13 at 20:58
  • I updated the question with screenshots on what happens in the proposed scenarios. If UAC is causing this, is that controlled by the file name, file path, or some kind of hash key of the executable. In other words, could I change the executable (or create a new one) that does the same thing but lives somewhere else, with a different hash signature? – Michael Butler Jul 9 '13 at 13:18
  • 1
    @MichaelButler: what is your antivirus? – stderr Jul 9 '13 at 16:49
  • See if the file has been blocked by Windows.

    Check the properties of the file, there may be a note saying This file came from another computer and might be blocked to help protect this computer To check for and unblock the file, follow these steps: Right-click the blocked file and then click Properties. In the General tab, click Unblock if the option is available.

  • Check to see if your antivirus is blocking the file.

    You can check to see if your antivirus software is blocking a file by temporarily disabling it, and then trying to open the file.


  1. Right-click the file or folder, and then click Properties.
  2. Click the Security tab.
  3. Under Group or user names click your name to see the permissions you have.
  4. Click Edit, then check the check boxes for the permissions that you need and then click OK.


enter image description here

Update 2:

Try this:

  • Right click, select Properties.
  • Click the Security tab.
  • Click Advanced.
  • Click the Owner tab.
  • Change owner to yourself.
  • Click Edit.
  • Check Replace owner on subcontainers and objects.
  • Click OK.
  • Properties didn't say anything about coming from another computer. Antivirus is VirusScan Enterprise (managed through a network). I can turn the auto-scan off via toggle switch, but this has no effect on opening, moving, or renaming the mv.exe file. – Michael Butler Jul 9 '13 at 18:02
  • Interesting. When I set permissions in the Security tab on the FOLDER, I get "Access denied" on setting permissions on the mv.exe. Screenshot attached. – Michael Butler Jul 9 '13 at 18:41
  • @MichaelButler: Updated my answer. See if you can now. – stderr Jul 9 '13 at 19:29
  • Update 2 worked. For me, what had happened was that I had installed Cygwin with one Windows user and tried to access from another. – thameera Nov 7 '14 at 5:47

The workaround was to re-download Cygwin's mv.exe utility, saving it as a different name like mvvv.exe (before actually downloading it, since I don't have access to rename mv.exe). Then, I set up a symbolic link to point mv to mvvv.exe so I can use it normally.

  • You should be able to create a symbolic link: ln -s mmv /usr/bin/mv to use mv on prompt and/or scripts. Except something is special with the filename mv on your machine... – mpy Jul 10 '13 at 18:26
  • Since McAfee seems like the problem, is my answer an option here (getting rid of this monster) ? – harrymc Jul 10 '13 at 18:30
  • @mpy Thank you! Brilliant workaround. A lot better than using an alias. 'mv' is fine since I'm in Cygwin and don't need "exe". "mv.exe" is the problem. I did a slink to mvvv.exe called mv and everything is normal now. – Michael Butler Jul 10 '13 at 21:15
  • @harrymc sorry Harry, while McAfee was the problem, I think a solution is the best answer (the symbolic link to a differently named mv.exe) – Michael Butler Jul 15 '13 at 13:07

Just in case that something went wrong on your disk with mv.exe, I would try to :

  • uninstall Cygwin
  • chkdsk
  • verify that mv.exe was deleted with its entire folder
  • reinstall Cygwin


You say that your antivirus is McAfee, which in my opinion is one of the most problematic of all antivirus products.

I would suggest to disable real-time protection in McAfee to see if the problem goes away. If it does, my own recommendation is to uninstall McAfee and install some other less-intrusive antivirus product.

  • You forgot the "replace the drive" and "reinstall Windows" steps. – Tony Oct 29 '15 at 13:18
  • @Tony: I'm much beyond that : now working on "Reinstalling the planet". Seriously, replacing McAfee is not on the same level as the actions you suggested. My company has had much trouble with client computers that had McAfee installed, so now I'm slightly allergic to it. – harrymc Oct 29 '15 at 14:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.