I am using Dell Studio 1555 for connecting to internet, everything was fine till yesterday I found that I am no longer being able to connect to any network. Even if by chance it gets connected it was automatically getting disconnected after few seconds. I made sure that network strength is full, so I tested this by sitting near to router too. But it was still not working.

I thought this might be caused by some software interfering the connectivity.. So, I made a clean install of Windows 8 (earlier I was using Windows 7), by formatting my PC. To my surprise it is still not connecting.


Now, the problem is that, I am not able to connect to any wifi network broadcast signals. It is stuck on "Checking Network Requirements" prompt. It seems no hardware problem because it is showing all the signals in vicinity and also showing good strength indicators. Also, I have other devices like my phone and another laptop, which are able to connect to same access point.

More Info:

This info might help somewhat-

  1. I am using Dell Studio 1555 with Windows 8 (32 Bit) installed.
  2. My WiFi adapter is Intel WiFi Link 5100 AGN.
  3. Wired Connection is working fine.
  4. I am able to see all networks in vicinity, but can not connect to them.
  5. Diagnotic Result file is available here.
  • This is usually drivers problem (at least on my experience). Find the drivers for your specific wifi cart that you have and install them.
    – Aristos
    Jul 3, 2013 at 6:35
  • Drivers are Ok, it is showing signal also connects sometimes(happens 1 in 50) Jul 3, 2013 at 7:40

2 Answers 2


The problem was hardware related, my hinges of laptop are weak, because of which the WiFi antenna cable which runs around the display screen got damaged. So, that's why I am able to see network but not able to connect to them.


I had the same story, many laptops couldn't connect to the wifi. It was an EnGenius ECB300 router. Even right next to the router it would reject the connection: "Checking network requirements" and then ... "Can't connect to this network".

I narrowed it down to being only from laptops with Qualcomm Atheros AR956x Wireless Network Adapters. I tried newer drivers where available, but still, could not connect.

But I found the reason. The router running on Channel 11 did not allow any connection to these wifi adaptors, but when I changed the router's channel to channel 1 for example, then they connect totally fine.

So, it might be that either the router or the AR956x wifi chips can't operate at the highest end of the wifi channel spectrum and therefore fail. So check what channel the routers are running at and try a lower one.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .