3

I have set up a new task in Task Scheduler (on Windows 8) to run a batch file and set the task to run each week day at 7:40 AM.

Weekly schedule

The task never runs (automatically). Next Run Time shows the correct time when the task should run, but when that time arrives the task does not trigger. There are no errors in the log, and the task runs without a problem when I start it manually.

Task list

I have other tasks that run almost identical batch files that are set to run Daily, and those work just fine. I have one other task that is set to run only on week days but at a different time, and that task also never runs automatically.

All these tasks are set to run as SYSTEM. The only apparent difference between the tasks that work and the tasks that do not is the schedule.

Here are the task conditions:

Conditions

The task runs on a desktop computer that is always on AC power. The computer does not sleep (tasks scheduled five minutes before and after this task run just fine).

Why is my scheduled task not starting at the scheduled time?

1

Even if you set the task to run at 7:40 it might start a half hour earlier or later. The Windows OS decides when it is gonna start the task exactly. I once hat a similar problem , check the conditions tab and unchecked the idle radio button which states that your process should run only if the PC is in idle state, this might solve your problem. Also on the condition tab check the other conditions you have, maybe some of these conditions are blocking your task from starting.

| improve this answer | |
  • I added information about the task conditions. I don't see how any of that could be blocking the task. – William Jackson Jul 8 '13 at 13:56
  • Weird, if you click in the schedule on run will the task start ? Try also to uncheck the two power conditions. If it does not help, set a different time, like 2 hours before or after 7:40 . If nothing happens delete the task and make a new one. Also try instead of SYSTEM to run it under a Administrator account. – Devid Jul 8 '13 at 14:32
  • 2
    None of your suggestions improved the situation. I fear this may be some kind of bug in Windows 8. – William Jackson Jul 11 '13 at 15:02
  • yes this might be a bug – Devid Jul 12 '13 at 11:20
1

check "logon as batch job rights" for your task account in computer group policy

| improve this answer | |
  • A bit more detailed info would improve this answer – Dave M Nov 21 '13 at 13:04
1

My fix was simple... I had already manually ran the scheduled task, but I created the scheduled task for the intent of using it daily... I had several TB to copy over to a backup server so I could not schedule the task just yet. My fix was to update the Start date to the current day, and that for some reason resolved it. Detailed info: Previous start date was Jan 3 which was when I created the task and manually ran it. The task was enabled to run daily and failed on Jan 5th. Went into the settings and updated the date to the current day (Jan 6), ran that night and completed on Jan 7). Location: Server 2012 R2, Task Scheduler, Open task, Triggers Tab, Open Trigger, Update Start Date to current day.

Hope this helps others.

| improve this answer | |
  • I'm not sure why this was downvoted, but I just had a very similar issue and reached the same conclusion. For whatever reason, it did not like that the start date/time was in the past, even though I had it set for a repeating schedule to run all day after the start. It would show the correct "Next Run Time", but when that time would come, it wouldn't trigger. It would just update the "Next Run Time" and do nothing else. I changed the start date/time to the next point in the future I'd want it to run, and then it worked fine. – Compeek Nov 2 '16 at 1:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.