19

When I play videos in mplayer it sometimes shows subtitles. How can I turn them off?

And can I change mplayer.conf so they are off by default?

  • Depends on the video, some videos have subtitles hard-coded in (i.e. overlayed on the picture, won't remove). Others have a separate subtitle track (external file)... Others still may have a track encoded in it that have them. But v is the keyboard toggle during playback. Types 2/3 this should work for - type 1 you are "SOL". – nerdwaller Jul 3 '13 at 21:56
  • Thanks v worked to turn them off. – Colonel Panic Jul 3 '13 at 22:52
  • Glad to help, moved it to an answer (as it should have been originally). – nerdwaller Jul 4 '13 at 1:17
23

Try hitting the v on your keyboard.

6

There are also CLI options -nosub (for disabling subtitles that come within an .mkv, for example) and -noautosub (for disabling external subtitles from a separate file).

So, to run a video without any subtitles, you can do the following:

mplayer -noautosub -nosub filename.mkv
3

Depends on the video:

  1. Some videos have subtitles hard-coded in (i.e. overlayed on the picture, won't remove).
  2. Others have a separate subtitle track (external file)...
  3. Others still may have a track encoded in it that have them.

But v is the keyboard toggle during playback. Types 2/3 this should work for - type 1 you are "SOL".

  • To complete your original ask… add the following line to your ~/.mplayer/config file… nosub = true. This will prevent the subtitles from being loaded at all, so you won’t have to type ‘v’. – mockman Dec 1 '13 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.