9

I'm using CentOS 6.4 (centos-release-6-4.el6.centos.10.x86_64). I'm trying to upgrade the php version from 5.3.3 to 5.4.4 by using:

yum upgrade php-mysql php-devel php-gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml

and

yum upgrade php

...but this is the only message i'm getting:

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: centos.netnitco.net
 * extras: mirror.wiredtree.com
 * updates: mirror.thelinuxfix.com
Setting up Update Process
No Packages marked for Update

I already ran:

yum update

and everything is in order. I also checked for exclusions of php-* in /etc/yum.conf but nothing was found. Any ideas? Thanks!

Update: solution

Thanks to @mirkobrankovic I ended doing this (on a 64-bit OS):

wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm
yum --enablerepo=remi upgrade php-mysql php-devel php-gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml
1
5

Maybe this question can help you.
Use the remi repository, you can't get it from CentOS base.
How to add remi repo

1
  • Thanks! One of the answers also recommend to download and compile the required php version. I think I'll try that as well.
    – Andres SK
    Jul 4 '13 at 12:55
9

To update PHP 5.3.3 to 5.4.4:

wget http://download.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
rpm -ivh epel-release-6-8.noarch.rpm
wget http://rpms.famillecollet.com/enterprise/remi-release-6.rpm
rpm -Uvh remi-release-6*.rpm
yum --enablerepo=remi upgrade php-mysql php-devel php-gd php-pecl-memcache php-pspell php-snmp php-xmlrpc php-xml
1
  • 1
    This worked for me.
    – zzy
    Oct 24 '15 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.