3

I recently applied the Windows 8.1 update. Everything went fine, except I can no longer access the Settings 'app' via the Start Srceen - I just get a blank screen or get sent back to the Start screen

If I create a new account, it works fine - just not my account.

The Event Log points me to Microsoft-Windows-TWinUI/Operational where I get the message

The application windows.immersivecontrolpanel_cw5n1h2txyewy!microsoft.windows.immersivecontrolpanel is not registered for the Windows.Launch contract or is not installed.

But struggling to find a solution to it. Found a couple of references online, but most seemed to relate to Domain based accounts and Group Policies, but I'm on a Microsoft / Local account.

Ran CHKDSK & System File Checker - but this didn't do anything either

Any suggestions?

2 Answers 2

1

I found a solution that worked for me here: https://social.technet.microsoft.com/Forums/windows/en-US/6f119828-dd1b-42da-b8b5-c6e6c0d5617c/no-apps-or-windows-store-work-after-upgrading-to-windows-81-enterprise?forum=w8itproinstall

  1. Fixing the app store:

    1. Open registry editor typing regedit.exe from a command line.
    2. Browse to the registry key at HKEY_CURRENT_USER\Software\Classes\Local Settings\software\microsoft\windows\currentversion\appmodel\repository\packages.
    3. Right click on the packages key and bring up the “Permissions” tab.
    4. Click the “Advanced” button located at the bottom right corner.
    5. Check to see the account name that shows up as the “Owner” (this is the first line of text on the “advanced security settings” dialog for the “packages” key). It should say SYSTEM. (For me this showed the built-in local Administrators group)
    6. If it is any other account, click on the “Change” button next to it.
    7. Type SYSTEM in the “select user” dialog. If “Multiple Names Found” window comes up, select the row for SYSTEM.
    8. Click OK to the dialogs and close them all.
    9. Run from admin command prompt: Powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml
  2. Fixing all modern apps:

    Run from admin PowerShell:

    ((Get-ChildItem "HKLM:SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\InboxApplications") | Get-ItemProperty).Path | Add-AppxPackage -Register -DisableDevelopmentMode

    • When I ran this the black X persisted until after the next step and reboot. But trying to start an app gives me a new message and a link to the store.
  3. Fixing 3rd party apps:

    Delete the regkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Appx\AppxAllUserStore\[UserSid]

  4. Restart.

    After a reboot the apps still showed the black X for a minute or so, but it soon cleared up on its own and all apps seemed to be working again. I was also able to update the apps from the app store once signing in with a Microsoft account. Finally, I am again able to get into PC Settings.

1

For whatever reason part of Windows Store apps became "unregistered" after Windows 8 to Windows 8.1 upgrade. I was able to get the "PC Settings" functionality back by running this command:

powershell -ExecutionPolicy Unrestricted add-appxpackage -register $Env:SystemRoot\ImmersiveControlPanel\appxmanifest.xml –DisableDevelopmentMode

which registers the PC Settings up again. Note that I also had to do the similar exercise for other apps too, most notably Windows Store itself.

1
  • Thanks, this fixed mine too. Do you have a list of the commands you run to get each app working? I don't know what to change in the command for each app.
    – ldam
    Dec 16, 2014 at 12:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.