A friend asked me if I could fix his laptop, with the description "black screen on boot". Having tried using his laptop I immediately noticed that the laptop's BIOS claims there is no hard disk connected. (errored with no bootable OS found)

Immediately my usual tricks were out the window -- usually booting up a portable installation of Ubuntu and using various software to check the hard disk health, etc, and recover data off it if needed, I did boot up Ubuntu anyway as it might get lucky, but no, no hard disks present. All the utilities off Ultimate Boot CD also couldn't see it, including MHDD32 and Drive Fitness Test (IBM/Hitachi).

Next I tried it on my desktop computer using a powered eSATA cable. The hard disk spins up and sounds completely normal. It also feels like it's spinning fine, with the usual odd gravity feeling when picking up a spinning hard disk. However Windows (7) doesn't see any disk is present. I tried via different eSATA ports on my computer (on different SATA controllers) to be sure. Hitachi's Windows Drive Fitness Test (WinDFT) also fails to spot the hard disk while connected to an eSATA port.

This leads me to believe 2 things could be wrong:

  • The firmware on the hard disk has become corrupted
  • The PCB has become damaged (less likely?)

Before I splash out on a replacement disk to harvest the PCB from, would anyone else have an opinion as to what has gone wrong with the disk, or any suggestions for repair? (I don't have access to PC3000 before you ask :D)

Hard disk details,

  • Hitachi Travelstar 5K750-640
  • Model number: HTS547564A9E384
  • Part numbers: H2T640854S / 0J15342
  • MLC: DA3931
  • HW/FW/PCB versions: A, A50A, A/A

3 Answers 3


Possible causes

  • SATA cable not connected fully or properly
  • SATA interface disabled in BIOS
  • SATA cable bad
  • SATA connector on motherboard broken, bent, or faulty (sounds like you eliminated this)
  • SATA connector on drive dirty, broken, bent, or faulty
  • Motherboard bad. Try different system.
  • Drive not getting enough power, try different power supply
  • If jumpers are on the drive, it may be in some weird diagnostic mode. Remove any jumpers.
  • Short on PCB
  • PCB damaged due to power surge, bad firmware update, bad NAND or NVRAM, or physical/liquid damage
  • BIOS doing something it doesn't like on power up. Try connecting drive to system after BIOS completes POST and see if you can view it with a boot disk or utility that rescans buses. Alternatively put it in an enclosure or connect to another system. Update BIOS is this is the issue.
  • Drive may be performing ATA SECURITY ERASE command. Leave connected to PC for 24 hours and then reboot and see if it comes back.
  • Issues with SATA cables/controllers are pretty much eliminated as I've tried a range of them in different SATA ports on my desktop computer too, via a standard eSATA cable and a Powered eSATA cable. Also tried using a ATA-to-USB device (uses external power), that gets detected as an unitialized disk in Windows Disk Management but at an unknown size -- Hitachi WinDFT still doesn't find it though. The disk also sounds too idle (spinning but no head activity) to be doing an erase command.
    – Adambean
    Jul 6, 2013 at 15:04
  • Also tried lightly hitting the disk flat on a table and freezing the disk. Neither helped, just spins up as before with a couple of clicks. :( I guess it's up to a specialist.
    – Adambean
    Jul 19, 2013 at 20:42

Sounds like the disk is dead. Just because the disk spins up does not mean that the head is moving. You can get a disk to spin up just by applying power. If the BIOS does not see the disk then there is no way anything else on the computer will detect the disk.

Unfortunately there is not much you can do to repair the disk yourself. Opening the disk is more risky than it sounds and will most likely cause more problems.

There are two lessons that can be taken away from a situation such as this:

1) Monitor the SMART disk information. Most likely this disk was giving errors for a while.

2) Always make a backup of your data. All drives will eventually fail.

  • I do hear the heads clicking/moving via the USB adapter device, but you're right it probably is dead. (The disk wasn't mine, I do use RAID1, multiple back-ups on my home server, and an off-the-RAID back-up too to protect my own data)
    – Adambean
    Jul 6, 2013 at 20:43
  • 2
    OP wasn't asking about the lessons which can be taken. He is looking for solutions.
    – Farhan
    Jul 13, 2014 at 18:09

I would suggest it is that the HD's on board electronics have failed, if it were a mechanical failure you would still see the drive in the bios.

  • What exactly are "HD's on board electronics"?
    – user201262
    Nov 23, 2013 at 4:35
  • He probably just means the disk's PCB. @ATech A mechanical failure could still result in a disk being undetected though, because the firmware is stored on the disk platters and not a solid state memory (flash/ROM) on the disk's PCB. The PCB is there just to provide the SATA connectivity and to operate the mechanical components if I remember correctly.
    – Adambean
    Nov 23, 2013 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .