I got a ISO which contains case-sensitive file/directory-names.

When mounting it on my Ubuntu 12.04 system using mount -o loop, all filenames are lowercase. There is an option called map=off, but when using that, all filenames are uppercase. What I found out during my research is, that ISO9660 doesn't support case-sensitive filenames by default. However, there is a extension called Joliet which does. My iso seems to be using joliet as it has case sensitive filenames when mounted on windows/mac os x. mkisofs does also support joliet.

However, I was not able to find a way to mount the ISO using joliet. How can I do that?

Dmesg does log [ 149.293945] ISO 9660 Extensions: Microsoft Joliet Level 1. Not sure why it isn't used though.

Edit2: You can find the ISO here: http://sourceforge.net/projects/cloverefiboot/files/Bootable_ISO/CloverISO-1914.tar.lzma/download

1 Answer 1


First make sure that the Joliet extensions have been enabled for your kernel. I imagine they are since you are using Ubuntu but check anyway, just to be sure:

grep -i joliet /boot/config-`uname -r`

That should return this line:


If the file is missing, try searching for joliet in /proc/config.gz. I don't have this file on my system, I am repeating what I read here.

Now, assuming you do have joliet enabled, my guess is that you have a CD that is not Joliet. I tried to replicate your issue by creating a joliet iso of two case sensitive files:

$ ls foo/
Aaaaa  Bbbbb

$ genisoimage -J -R -o foo.iso foo/
I: -input-charset not specified, using utf-8 (detected in locale settings)
Total translation table size: 0
Total rockridge attributes bytes: 323
Total directory bytes: 0
Path table size(bytes): 10
Max brk space used 0
181 extents written (0 MB)

$ sudo mount ./foo.iso baz/
mount: warning: baz/ seems to be mounted read-only.  <-- ignore this, not a problem
$ ls baz
Aaaaa  Bbbbb

In other words, as long as an image was created using the Joliet extensions it should be mounted case sensitive by default. I am really not an expert on image file systems but perhaps the problem is not Joliet but something completely different. Can you mount case sensitive if you do the same steps I did above?


I downloaded your iso and get the same behavior you describe, I can't mount it case sensitive. I did find a possible reason though. I ran isoinfo on both your file and mine:

$ isoinfo -d -i Clover-1914-X64.iso | grep Joliet
Joliet with UCS level 1 found
$ isoinfo -d -i foo.iso | grep Joliet
Joliet with UCS level 3 found

I have no idea what the difference between Joliet levels 1 and 3 is but I suspect that is why your iso is not working properly. This might at least give you a new avenue of research.

  • Hi, you are right! Actually, when creating a .iso myself it does work. No idea why this iso I am trying to mount doesn't work. I added the link to it in my OP. Maybe you can try it out! Thanks :-)
    – Zulakis
    Jul 9, 2013 at 10:57
  • @Zulakis see updated question.
    – terdon
    Jul 9, 2013 at 14:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.