The codec allows you to preview the recording you just took. The recorder itself and the encoder both seem to work just fine, but when I try to preview a recording it says it can't find the codec. The codec is definitely there and in the same directory. The error

The codec in the same directory as everything else

EDIT: I have tried reinstalling. It did not fix the problem. I am having the same problem on 2 other XP machines as well

EDIT: I tried re-registering the codec per Aaron's suggestion. The registration succeeded, but I still get the same error when I attempt to preview a recording

EDIT: After doing some more research, I was able to find a version of MS Expression 4 Encoder "without codecs." Surprisingly, this version works perfectly fine on Windows 7 with no errors, but the exact same installation produces the same errors I have already described when I try to preview recordings in Windows XP. How do I get the program to work as well on XP as it does on 7?

  • What software are you using to preview the video? Cannot tell if it is Expression or something else like VLC. – kobaltz Jul 8 '13 at 16:48
  • It is Expression's previewer. I added pics – Michael Jordan Jul 8 '13 at 16:53
  • 1
    What happens when you reinstall Expression? It may relink/register the DLL. – kobaltz Jul 8 '13 at 16:57
  • 1
    You might also try re-registering the codec DLL manually in Command Prompt, via the regsvr32 command; the actual invocation might be something like regsvr32 c:\path\to\codec.dll. – Aaron Miller Jul 8 '13 at 17:29

Try uninstalling the Codec and re-installing it. Get it from this link: http://www.microsoft.com/en-us/download/details.aspx?id=10732

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.