The pictures below explains it well, but it seems Windows will not let me place a 8.16 GB .vhd file on a flash drive with 14.6 GB of free space.

Screenshot from Windows 7

  • 21
    Note that the error message explicitly mentions the file system and not the drive!
    – Bakuriu
    Jul 9, 2013 at 8:09
  • In addition, it could be that the file has "holes" in it that have not been allocated yet -- this is often seen with disk images. Copying that file will yield a file without holes. This is not the problem at hand, but may come up in the future. Jul 9, 2013 at 10:28
  • Your file is of an illegal size on FAT32 formatted drives. The error message specifically mentions this fact.
    – Ramhound
    Jul 10, 2013 at 21:17
  • @Ramhound I understand that now, thank you. Initially all I saw was the top of the dialog "File Too Large".
    – KDecker
    Jul 10, 2013 at 21:24

4 Answers 4


It's formatted as FAT32. The largest size file supported on FAT32 is 4GB. You will have to reformat the drive as NTFS or ExFAT.


The issue is that the target filesystem is FAT32, which only supports files up to 4 GB in size. The error message is not very clear if you've never run into this issue before. You can fill the 14.6 GB space with multiple 4 GB files, but no single file may be larger than 4 GB. You'd need to reformat the disk as NTFS or exFAT to support larger files.

  • 22
    Actually, the error message says it all: "The file is too large for the destination file system".
    – gronostaj
    Jul 9, 2013 at 8:21
  • 13
    It's still not a good error message as many users will not know the difference between the notions of partition, volume, file system, ... It's technically correct, but it pretty much only makes sense to those who know the FAT32 size limit anyways.
    – us2012
    Jul 9, 2013 at 11:36
  • 4
    @us2012: That's a fair sight better than previous versions of Windows which would return a far more cryptic "access denied" generic error message.
    – afrazier
    Jul 9, 2013 at 12:55
  • 3
    Microsoft should put a "What's this" thing on the dialog. Something that tells inexperienced users what is happening. Have they learned UX?
    – Andrew Sun
    Jul 10, 2013 at 1:22
  • @ascom yay for the Paperclip... Microsoft tried to do that, people hated it (or an extremely vocal group claimed to, making it appear as if there was general dislike across the user community) so Microsoft wisely decided to do away with such things.
    – jwenting
    Jul 10, 2013 at 8:10

In addition to David Marshall's answer, there's no need to reformat the drive. You can upgrade from FAT32 to NTFS with the convert command.

>convert /?
Converts a FAT volume to NTFS.

CONVERT volume /FS:NTFS [/V] [/CvtArea:filename] [/NoSecurity] [/X]

  volume      Specifies the drive letter (followed by a colon),
              mount point, or volume name.
  /FS:NTFS    Specifies that the volume will be converted to NTFS.
  /V          Specifies that Convert will be run in verbose mode.
              Specifies a contiguous file in the root directory
              that will be the place holder for NTFS system files.
  /NoSecurity Specifies that the security settings on the converted
              files and directories allow access by all users.
  /X          Forces the volume to dismount first if necessary.
              All open handles to the volume will not be valid.
  • 6
    It's always a good idea to back up your files before using convert though - just in case something goes awry!
    – nhinkle
    Jul 9, 2013 at 19:00

FAT-formatted drives can't see files larger than 4 GB; you'll have to reformat it as NTFS. You may have a directory that is 100 GB in size. However, no single file may be more than 4 GB.

The maximum possible size for a file on a FAT32 volume is 4 GB minus 1 byte (232−1 bytes). Video applications, large databases, and some other software easily exceed this limit. Larger files require another formatting type such as NTFS.

Ref.: Wikipedia article on FAT32.

  • 3
    Cannot hold.. Jul 9, 2013 at 22:17
  • FAT and FAT32 are not the samething the linked table is horrible
    – Ramhound
    Jul 10, 2013 at 21:20

Not the answer you're looking for? Browse other questions tagged .