1

It's been about two weeks since upgrading to the Windows 8.1 Preview, and I haven't gotten a single toast from an app. There have been many restarts, and everything is up to date as far as Windows Update and the Store are concerned.

I used to get toasts from email, calendar, messaging, Skype, Xbox Live, etc. but I never get anything now, and I'm not sure how to troubleshoot.

I've tested email by making sure the program was running in the background and sending myself an email from a different address via webmail. I was never notified.

How can I troubleshoot this?

  • Are you sure toast notifications didn't get turned off somehow for all apps during the upgrade? – Karan Jul 9 '13 at 16:55
  • @Karan I'm not sure how to check. The apps don't seem to have any related settings. The closest thing I can find is just the global Notifications setting in the Charms menu. But the only options are to mute notifications for x amount of time. – Louis Jul 9 '13 at 18:02
  • @Karan It was already enabled, but after toggling that, I'm getting mail notifications again. Seems to be working! – Louis Jul 9 '13 at 18:28
  • Good to know! I added it as an answer below for future readers. – Karan Jul 9 '13 at 18:31
1

Just go to Settings charm / Change PC settings / Search & apps / Notifications and enable toast notifications for the relevant apps (toggle the setting if already enabled):

1

0

To change which notifications appear here

  1. Swipe in from the right edge of the screen, and then tap Settings. (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Settings.)

  2. Tap or click Change PC settings, tap or click Search and apps, and then Notifications.

  3. Under Show notifications from these apps, set the app you want to On or Off.

To hide notifications temporarily in this area

  1. Swipe in from the right edge of the screen, and then tap Settings. (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Settings.)

  2. Tap or click Change PC settings, tap or click Search and apps, and then Notifications.

  3. Turn on Quiet hours and choose how long you want notifications hidden.

  4. If you want to turn them back on before the time period is over, turn off Quiet hours.

To change notifications for a specific account

Mail lets you manage notifications for each account. Here's how:

  1. On Start, tap or click Mail.

  2. Swipe in from the right edge of the screen, and then tap Settings. (If you're using a mouse, point to the lower-right corner of the screen, move the mouse pointer up, and then click Settings.)

  3. Tap or click Accounts.

  4. Choose the account you want to change notifications for.

  5. Under Show email notifications, tap or click the option you want.

source: http://windows.microsoft.com/en-CA/windows-8/how-manage-notifications

I tried other methods found on the internet but this one worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.