0

Typing Get-ExecutionPolicy in PowerShell as Administrator returns Restricted, but when I run Powershell as User Account and type Get-ExecutionPolicy it returns Unrestricted. Why is that ? I thougt setting the ExecutionPolicy to Restricted in PowerShell as Administrator would also change the ExecutionPolicy of the User Account. Is this normal or am I doing something wrong ? How can I change the Execution Policy from my Group Policy ?

As Administrator Account powershell as admin
As User Acount powershell as user

1

The per-user scope of the Powershell execution policy overrides the machine-wide value, like most user preferences do. In order to enforce a given policy on users or machines, you must enable the appropriate Group Policy setting (shown in your powershell output as the MachinePolicy and UserPolicy scopes) See http://technet.microsoft.com/en-us/library/hh849812.aspx.

  • So how can i do this ? I have to do it from my Group Policy bu where is the setting ? – Devid Jul 10 '13 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.