VMware Workstation 7 on Win7-64 (Home Premium).

I have confirmed this on any guest running on this machine (from winxp to debian).

I am using a bridged network connection for my guests (Automatic on VMnet0). All of the network configuration is done with DHCP (including on the host).


What I can not do:

  • Ping my host machine from inside any VM. (either shows me "Destination Host Unreachable" or will just timeout)

What I CAN do right after power up, with no problems at all.

  • I can connect to the internet from inside the VM
  • I can ping my router from inside the VM
  • I can ping other machines on my network from inside the VM
  • Other machines can ping the VM
  • Other machines can ping the host
  • My host machine can ping the VM (this one is important. read further)


So I have my router assigned as, and the router provides the DHCP service (and it seems to be doing so successfully).

There are no IP conflicts on the network that I am aware of. All Gateways and Subnet masks are appropriate and matching.

My entire workshop is on one single subnet, with one single DHCP server and gateway.

There is one method in which I can ping successfully, but it requires an active connection initiated from the host (I start pinging from host to VM). During the period of the active connection, I can successfully ping from VM to host, using explicit IP address. As soon as the host connection is closed, the VM ping starts hanging with the same old messages.

My Thoughts

This really feels like a firewall problem, but I have turned off all firewalls on host and VM, powered down the network, powered back up, and the problem still persists. And if it was firewall, why would only the IP address associated with bridged VM networks be blocked.

I feel as though my host operating system (Win7) is somehow configured incorrectly, or, VMware Workstation is configured incorrectly from the host side. Although I have done my best to put everything in default, I feel like I am missing something silly.

  • 1
    Did you resolve this? I'm having the same problem serverfault.com/questions/524310/…
    – mowwwalker
    Commented Jul 18, 2013 at 8:35
  • At the risk of sounding like a jerk - and only because it just worked for me - "Have you tried turning it off and on again?" The host PC, I mean.
    – marklark
    Commented Apr 6, 2015 at 20:45
  • There seems to be more than one reasonable answer if you read down below, as it also seems there may be a few different causes that can create this problem. The best quick answer, is that somehow your host network adapter (the one you are bridging) is incorrectly set up or has other software interfering with it. Below you should find directions on where you might start looking. Commented Oct 18, 2015 at 23:00
  • Is the physical network adapter you are bridging actually connected to anything? If not, there is your problem - at least in some cases, windows will more or least completely shut it down if no link is detected. Commented Apr 8, 2018 at 2:29

7 Answers 7


I had same problem: couldn't ping to <-> from host and guest. Other networking was fine. I unchecked the DNE LightWeight Filter I had installed and it fixed the problem. Thanks to Walkerneo's comment. My DNE filter came from Citrix.

  1. Network and sharing center
  2. Select your adapter that has Internet
  3. Click properties button from the Connection Status Window
  4. Uncheck DNE LightWeight Filter in the Adapter's properties
  5. Click OK and wait for your adapter to reset itself
  • 1
    I was pulling my hair out at this, and it worked perfect! Thank you!
    – Kyle Lowry
    Commented Nov 8, 2013 at 7:11
  • 1
    Holy smokes. I had forgotten I have DNE installed (installed it for some random Cisco VPN client fix). Thanks!
    – freb
    Commented Sep 27, 2014 at 22:51
  • 3
    I have changed my hostOS since the original post, no longer have this problem, and therefore can no longer verify the actual problem/solution myself. This was voted the most popular so I am going to mark this as the accepted answer. Although I did not use Citrix, I can recall a number of programs I installed that may have placed a filter on my network adapter without me realizing it was there, and could have been a very likely cause in my own case. Commented Apr 7, 2015 at 13:06
  • Connectify had similar filter too.
    – Leone
    Commented Sep 10, 2020 at 12:58

You need to enable the VMware bridge protocol on the host.

Go to Network and Sharing Center. On the right side there will be a list of connections (Access Type: Connections), select the VMware Network Adapter. Open Properties, check the VMware Bridge Protocol box and exit the screen.

  • 1
    Am using bridged mode and my RHEL is configures with public ip. and am not ableto ping from outside Commented Nov 6, 2014 at 6:20

I have similar issue and managed to solve it. I have both Virtualbox and VMware Workstation installed. VMware's VMnet0 tries to use my Physical Adapter, but [Virtualbox Bridge Network Adapter] instead of [VMware Bridge Protocol].

I solved it by doing the following:

1) Disable [Virtualbox Bridge Network Adapter]

2) "Restore Defaults" for VMware's "Virtual Network Editor"

3) Reselect VMnet0's "Bridged to:" to my Physical Adapter

But this time without Virtualbox Bridge Adapter conflict, it will use the [VMware Bridge Protocol]


For me it was because of Check Point Endpoint VPN client. Once uninstalled, it worked like a charm.

Even though I checked the adapter properties and disabled all options other than the bridge for VMware, it still didn't work, hence the reason why I uninstalled Check Point VPN client.

Hope this could also help !


So far, my conclusion is that the bridging mechanism is somehow causing the problem. I also feel that this may be version/OS specific, as I do not recall this problem in the past (although, I may be wrong).

When using a second NIC on my host machine, my VM is able to ping that NIC, but not the NIC that is providing the bridged connection. (each NIC has a different IP address)


There was definitely something altering the bridged connection, although I have re-installed the operating system recently, so I cannot conclusively say what the the issue or solution was. Problem never re-occurred (although I was much more selective about the software I installed, which might suggest the now accepted answer)

  • 3
    Hello, I just solved this problem for myself! It was because of the driver SonicWall installs. I'm curious to know if this (or something similar) solves the problem for you as well. Try right-clicking your network adapter, going to properties, and seeing if anything out of the norm shows up. Disabling 'DNE LightWeight Filter' worked for me. Good luck!
    – mowwwalker
    Commented Jul 19, 2013 at 4:24
  • 1
    @Walkerneo You should post this as a proper answer, as your comment helped at least two other people who posted answers to confirm it.
    – slhck
    Commented Oct 4, 2013 at 9:46

I had the same problem, what really solved my issue is enabling Adhoc support 802.11n for the active network adapter.

What you have to do is,

  1. Go to My Computer properties
  2. Under Network Adapters, right-click on your network adapter and go to Properties
  3. Go to Advanced tab.
  4. Set the value of Adhoc support 802.11n to Enable.

In 2022, with Windows 10/11, if the VMNet Bridge Driver is set to automatic, then a Hyper-V virtual adapter may be chosen to your detrement. However, if you explicitly choose an adapter, then you have one less point of failure in your debugging, or bridged networking may just happily work again.

select bridge adapter

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .