I want my Raspberry Pi to use OpenDNS to resolve domain names. How can I modify this setting?

  • what OS are you using? There are multiple OSs for the Raspberry Pi
    – Keltari
    Commented Oct 24, 2016 at 1:46
  • 2
    Note for future users finding this answer via Google etc: Editing /etc/resolv.conf isn't really the right way going about this anymore: You need to edit /etc/dhcpcd.conf instead. See my answer below. Commented Apr 3, 2019 at 14:51

6 Answers 6


If you are using Debian on Raspberry Pi, then you need to edit /etc/resolv.conf

nano /etc/resolv.conf

then add the server IP of the openDNS


Btw, if you have any concern about speed of the DNS you may want to take a look at this post

  • I did this, but it's still not using OpenDNS. Commented Jul 10, 2013 at 5:53
  • 4
    you restarted your board and are using Debian-server, right? If it is the case, please try to add nameserver``and nameserver` to /etc/network/interfacesthen restart your board or do /etc/init.d/networking restart. If it is still not working, please paste output of dig google.com
    – Angs
    Commented Jul 10, 2013 at 6:07
  • Should the IPs be in both /etc/resolv.conf and /etc/network/interfaces? Commented Jul 10, 2013 at 15:36
  • 1
    The /etc/resolv.conf entry is created from the /etc/network/interfaces config. Note: this works only if you're using static network configuration. If you're using dynamic settings, then you'll need to change the settings provided by the DHCP server.
    – joatd
    Commented Jul 13, 2013 at 13:58
  • I just wanted to mention that today out of the blue, my Pi3 device couldn't see mirrordetector.raspbian.org. I added the OpenDNS addresses and it works fine. (I had Google's in there...)
    – kodybrown
    Commented Jan 14, 2017 at 21:33

I've found that in the latest version of Raspbian (stretch I think?) you now need to edit the last line of /etc/dhcpcd.conf. There should be a line that starts with static domain_name_servers= - there you can customise it with a list of space-separated DNS servers, like this:

static domain_name_servers=

DNS Servers Featured: Cloudflare, OpenDNS, and Google

Edit: As @DavidOliver points out, you may need to restart dhcpcd too: sudo systemctl restart dhcpcd.service.

  • 4
    This was the only solution that worked for me. I am using raspbian for the raspberry pi
    – Tono Nam
    Commented May 24, 2018 at 15:37
  • 1
    This one was the one that worked for me on Raspbian - From the other answers in this question, edits directory to resolv.conf got overwritten on reboot and the network/interfaces edits were ignored
    – dlrust
    Commented Oct 29, 2018 at 23:24
  • 1
    This should be the correct answer for latest (Raspbian Stretch or Debian Stretch), the accepted answer in 2013 and the higher vote so far of modifying etc/resolv.conf are simply no longer correct.
    – hcheung
    Commented Apr 3, 2019 at 6:06
  • 2
    Seemed like a restart of the service was necessary: sudo systemctl restart dhcpcd.service Commented Aug 7, 2019 at 21:47
  • 1
    @TomasZubiri It's actually changed quite a bit over the years. The method Described in my answer is most up-to-date version. Answers that suggest to edit /etc/resolv.conf are outdated because that file is now automatically populated with the current DNS resolution settings, and is auto-updated by NetworkManager/systemd/whatever. Commented Mar 16, 2020 at 15:24

Don't edit /etc/resolv.conf since that file is generated automatically. Instead edit /etc/network/interfaces and add the following to the end:

  • 7
    resolv.conf is just overwritten by the resolvconf tool. If this tool is not installed the first answer will work. But your solution will work anyway, that's why it should be marked as the right solution.
    – Ben
    Commented Dec 7, 2016 at 18:18
  • this worked for me on raspian stretch lite, thanks!
    – james-see
    Commented Sep 13, 2017 at 1:28
  • didn't work. startbeamrainbowlabs' solution worked!
    – lode
    Commented Aug 13, 2019 at 22:16

I have found the answer from another website and this is the best. I used the very last part of the article as Raspbian comes with dchpcd already installed and i still want an automatic ip address not a static ip address. Running from a Raspberry Pi3 multiboot [berryboot] with Raspbian - Pixel type

sudo nano /etc/resolv.conf.head

in your terminal. You will have a blank slate to work with. Next copy and paste the following code:

#OpenDns Servers

click on cntrl + x to exit out and select y for the following options to save. restart your Raspberry Pi with

sudo reboot

To make sure you are using OpenDNS go to the following website: OpenDns welcome page

  • Could you add a link to the original forum source you found this answer on? Commented Apr 18, 2017 at 19:36
  • I have found the exact link [old article from 2013 but works!] I have updated my answer to reflect the link Commented Apr 18, 2017 at 20:07
  • Sweet. Context almost always makes a question better. Commented Apr 18, 2017 at 20:11
  • I hope this has helped you. By the way the bootloader i use for my Raspberry PI3 is berryboot [berryterminal.com/doku.php/berryboot] and i love it! I have Raspbian-Pixel, Kali Linux2.0, OSMC, and RetroPie v3.6 running on a 16GB sd card without having to change sd cards. You can get the images for berryboot here: [berryboot.alexgoldcheidt.com/images/] In fact I'm using Raspbian and chromium to answer you. Commented Apr 18, 2017 at 20:19
  • This worked for me. I really don't understand why setting up networks is becoming more and more complex and intransparent over time.... THanks for your help!
    – Tarator
    Commented May 4, 2017 at 6:17

The openDNS servers worked for me thanks. During a Udemy learning session I had run into a problem after ditching my wifi sharing arrangement with my Mac, and setting up ethernet hub with the PI on a different home network. The problem with my previous IP sharing arrangement with WiFi.

When I originally setup the PI with the sharing arrangement the text Inside the resolve file was:​


which was entered automatically by the minibian OS, NOT ME!

This IP became the default DNS server, with the MacMini seamlessly providing the real DNS in the background. ​



​Then I could ping google.com Thank goodness for forums!

  • 1
    What does this do and how will it help? Read over "Why do I need 50 reputation to comment" to ensure you understand how you can start commenting. Commented Sep 4, 2017 at 2:27
  • The instructions here are incomplete. Which file needs editing? Where is it located? Are there any other steps one must complete before your solution solves the issue, and how can one verify the issue is solved? Commented Feb 4, 2021 at 15:51

Add this line into file /etc/dhcp/dhclient.conf:

option domain-name-servers,,

Then it will work.

  • 5
    The first IP address is a random private address. The other two are the IP addresses of Google servers - not OpenDNS. Commented Sep 1, 2015 at 9:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .