1

So I broke out this game the other day, blew the dust off of it, and popped into my PC's cup holder eagerly anticipating the epic pirating that was soon to commence. Imagine my disappointment when the game refused to let me install it. I've done quite a bit of research and I cannot find anyone that is having the same issue as I am. I have found some helpful tidbits, though.

At first. when InstallShield was checking Windows version, preparing to install, etc., it would suddenly stop and present me with a dialogue box that said "1628: Failed to complete installation." After some research I determined that this was an issue with InstallShield, and the suggested fix was to delete my InstallShield folder and attempt the installation again. This actually helped, and progress was made.

Not much progress, though. Now all of the initial Windows version checks and installation preparations complete and those windows go away as they should. I never get the next window, though. By next window I mean the one where I start choosing where to install the program and the installation actually occurs. When I check my Task Manager, IDriver.exe is in my list of processes using about 10 MB of ram and fluctuating between about 10-12 processor usage, but it never does anything. I thought maybe it would just take a bit of time, but I've decided it's just never going to work. I started the installation and just let IDriver.exe do it's thing while I wrote a paper for my college coursework, and it never kicked up a new window to install the program. Also, even though it's computing something with my processor, I don't think it's actually doing anything because the amount of memory used never changes.

The last bits of information I have for those of you that are hopefully more tech minded than I are that I'm using Windows 7 64bit, setup.exe on disk one is running in WinXP SP2 mode, and I've given it admin access. I know this question is about installing a specific game, but it seems to possibly be more of a Windows Installer issue. Many others are enjoying this game with Windows 7, so I'm sure there's something I can do on my machine to fix this.

  • Do you have UAC turned off? This may be an issue that Windows needs admin permissions to install the game, but the installer doesn't know to throw up a prompt for credentials. – Kruug Jul 10 '13 at 18:36
  • The first thing I would do use update your Windows XP virtual machine ( thats what XP Mode basically is ) installation to Service Pack 3. The next thing I would do is simply run the installation in Windows XP compatability mode instead of the Windows XP mode which is actually a virtual machine and horrible for applications that required DirectX. – Ramhound Jul 10 '13 at 19:01
  • @Kruug - I just tried your suggestion and unfortunately no luck. I completely disabled UAC, restarted, and attempted installation and the behavior is exactly the same. – Dave Jul 10 '13 at 19:10
  • @Ramhound - I have actually tried several of the compatibility modes with Windows XP SP3 being the first I tried. None are behaving any differently. I'm not sure what you are referring to in the second part of your comment, though. I'm using the compatibility mode settings under Properties -> Compatibility near the top of the dialogue box. Where else can I configure things to run in XP mode? – Dave Jul 10 '13 at 19:13
  • @Dave - Windows 7 Professional has a feature called "XP MOde" its actually a virtual machine. What you describe is a feature that exists in Windows XP called Compatability Mode. Which one are you talking about exactly. – Ramhound Jul 10 '13 at 19:19
1

This Application Compatibility Update explicitly mentions adding support for Sid Meier's Pirates!, so get it here (32-bit) or here (64-bit), install it and then try running the game in normal (not compatibility) mode (use compatibility mode only if normal mode fails).

For best results ensure your copy of Windows is updated, since there may have been further compatibility updates as well.

  • This is a solution I've discovered and tried as well, but when I downloaded the file from Microsoft's site, it told me that it was "not applicable to my computer". I thought maybe I had accidentally gotten the wrong version, but I checked, double and triple checked, and it was indeed the right version. I keep my Windows pretty up to date, so I figured that I may have it installed already. Thanks very much for the suggestion, though. – Dave Jul 10 '13 at 19:37
  • Perhaps it gave that error message because it's meant for Win7 32-bit. I added a link to the 64-bit version of the update above. Can you try that instead? – Karan Jul 10 '13 at 21:13
  • If you would update your question with a screenshot of the error message because the compatibility mode is the normal solution for this problem. – Ramhound Jul 10 '13 at 21:22
  • @Ramhound - A screenshot would be excessive since it's simply a dialogue box that says "The update is not applicable to your computer" with nothing else in it except an "OK" button. I downloaded the 64bit version, which is appropriate for my installed version of Windows 7. – Dave Jul 10 '13 at 21:27
  • @Karan - Or if you mean a screenshot of the error message when I try to install the game, there is none. The installer says it's checking my Windows version, then preparing to install. After this the window disappears, and the actual installation window never shows up. – Dave Jul 10 '13 at 21:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.