I have a samba server set up on a Linux computer that uses winbind on an AD domain. Everything seems to be working but I haven't been able to mount a samba share on another machine. Right now, I would just like to mount my home directory in a folder on another linux machine.

When I do:

smbclient -L mycomputer -U myuser

It asks for my password and I authenticate fine. It then lists my home directory as a share:

# smbclient -L mycomputer -U myuser
Enter myuser's password:
Domain=[MYDOMAIN] OS=[Unix] Server=[Samba 3.6.9-151.el6]

    Sharename       Type      Comment
    ---------       ----      -------
    IPC$            IPC       IPC Service (Samba Server Version 3.6.9-151.el6)
    myuser          Disk      Home Directories

Domain=[MYDOMAIN] OS=[Unix] Server=[Samba 3.6.9-151.el6]

    Server               Comment
    ---------            -------

    Workgroup            Master
    ---------            -------

However, when I try to mount the share and enter my password, I get this:

mount -t cifs //mycomputer/myuser /mnt/cifs -o username=myuser,domain=MYDOMAIN
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

I have tried all sorts of combinations for the -o parameters like MYDOMAIN/myuser, putting MYDOMAIN.COM, etc. but it just doesn't seem to make any difference.

My samba config for these shares is as follows:

    comment = Home Directories
    browseable = no
    writable = yes
    valid users = MYDOMAIN\%S

Can someone please provide some insight as to why I cannot mount this share? Thanks!

EDIT: I figured that I should add that I tried to mount the share on Windows as well as Mac OSX and it isn't mounting on either. I couldn't get exactly what the error was on OSX as it just gave me a "check with your system administrator" message. I would assume this means it is an issue with the server config, but what?

  • I cannot remember if it was the same error message, but after struggling very hard to get a windows share mounted via cifs it turned out that I needed only another option: iocharset=utf8, which seemed to have nothing to do with the error. Perhaps it's worth a try...
    – mpy
    Jul 11, 2013 at 14:58
  • seemed plausible but that didn't do it :(
    – Marty
    Jul 11, 2013 at 15:01
  • Can you browse/mount the share on the same machine on which the share exists? (Start->Run-> "\\mycomputer\myuser")
    – dtmland
    Jul 11, 2013 at 15:19
  • No, I am not able to mount it on the server machine either. I'd like to point out that I'm serving the share from samba on Linux, not Windows.
    – Marty
    Jul 11, 2013 at 15:22

1 Answer 1


Try adding path info to your homes:

path = /PathToHomesHome/%u
# like:
path = /home/%u

And if possible try without valid users restrictions.

And if smb is running as a different user remember that the directories in full path to your "home" will need to have at least +x for the samba user (depending on your setup, could require it for other o+x

On server you can also run testparm to see your setup.

To debug local mount.cifs try first

smbclient //mycomputer/myuser -U myuser 

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.