My motherboard (P8Z77-V PRO) has 2 USB 3.0 headers on it. One by Intel and one by Asmedia. Currently running Windows 8 Pro 64-Bit and my case is a Corsair 550D.

A HyperX USB 3.0 stick plugged into my front panel USB 3.0 port connected to the Intel USB 3.0 header constantly disconnects when connected during transfers and even when idle. Any USB 2.0 device works fine on the Intel header.

While I could simply use the Asmedia header and be done with it, it doesn't explain why the Intel header which is native to the chipset is not functioning as expected for USB 3.0 devices.

I'm unable to determine if there's any bad hardware here since every scenario I've been able to test what "could" be failing hardware succeeds in another scenario.


HyperX USB 3.0 stick: Works fine on Asmedia header and rear panel USB 3.0, just not the Intel header.

Front Panel USB ports: They work fine on the Asmedia header, just not the Intel one over USB 3.0. USB 2.0 is fine.

USB Headers/Controllers: The USB 3.0 blocks on the rear for the Intel header work just fine, yet the front panel doesn't.

Drivers: Tried a clean install of Windows 7 using the Intel USB 3.0 drivers and a Windows 8 Pro install with Microsoft's drivers and they both failed doing transfers on the front panel USB 3.0 on the Intel header

  • I have tried the stick on the Asmedia header and it appears to work fine.

  • I have tried the stick on the 4 USB 3.0 rear panel ports (2 by Intel, 2 by Asmedia) and they work fine.

  • I have tried other USB 3.0 storage devices on my front panel Intel header and they work fine.

  • I have tested a clean install of Windows 7 using the Intel USB 3.0 drivers and Windows 8 using the Microsoft USB 3.0 driver and they both fail on the Intel header still ruling out the software being the problem.

  • It's unlikely to be power related since I can connect an powered external HDD over USB 3.0 to the front panel and transfer data to the HyperX stick just fine. However flip that around with the HyperX stick in the front and the HDD in the rear and the transfer fails.

  • I have scanned the stick for errors and none have come up using chkdsk.

  • I disabled power management in devmgmt and that didn't do anything.

  • Disabling "Intel xHCI Mode" in the UEFI BIOS causes the Intel header to work again, but only @ 20 MB/s vs the 50 MB/s+ I was getting over xHCI.

  • The stick works fine in other PCs.

"the volume for a file has been externally altered so that the opened file is no longer valid" is the message I receive when the drive disconnects during a transfer.

Kingston's FAQ for the HyperX drive states to use the rear USB ports when "the unit is either not recognised or I receive an error message." Yet the Asmedia header works fine for the front USB 3.0 ports.

I have run out of ideas as to what could be causing the issue and what could fix it.

The only thing I can think of would be to start replacing hardware and see if that fixes it but it seems unlikely given the scenarios I've tested that the hardware could be a factor?

1 Answer 1


After testing out a new USB 3.0 stick, a new motherboard and finally an alternate add-in 3.5" front panel USB 3.0 ports. It turns out the front panel USB 3.0's on my case were causing the dropouts as the alternate add-in bay didn't cause them.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .