This question already has an answer here:

I accidentally pulled out my USB flash drive while formatting. Now when I insert it, a window pops-up saying it needs formatting. But formatting fails because it says that the stick is write protected. I tried using disk part, low level formatting, command prompt using admin. Nothing worked.

Does anybody know another method I could try?

marked as duplicate by bwDraco, Kamil Maciorowski, Mike Fitzpatrick, Pimp Juice IT, fixer1234 Jan 26 at 20:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    Try using Linux. – Karan Jul 12 '13 at 3:48
  • If you're really lucky, you may have some luck with a firmware flash, if you can find out the microcontroller chip number. Otherwise, the drive is gone. Consider the data gone already (and this, folks, is why backups are good). – Bob Jul 12 '13 at 6:22

Try using CCleaner.

You can navigate to Tools>Drive Wiper in CCleaner and wipe the flash drive. Set it to wipe the entire drive, set it to however many passes you'd like (just one is fine) and be absolutely, completely sure you select the right drive.

After that, format it by pressing Windows Key+E to open Explorer, and the right-clicking (Format...) in the context menu. Set it to defaults and you're good to go.

Do be aware that all of these operations will take a considerable amount of time, and that your data will be unrecoverable. If you need to salvage anything from the flash drive first, it is a bit more involved but not unmanageable.

1.Go to Run->regedit

2.MyComputer->HKEY_LOCAL_MACHINE->SYSTEM->CurrentControlSet->Control -> StorageDevicePolicies

3.Double click the key WriteProtect in the right pane and set the value to 0

4.In the Data Value Box, press OK

5.Exit Registry, restart your computer and then re-connect your USB pen drive to your computer.


HP USB Storage Format tool


Neo 9 tool able to get past the write protection and format the pen drive

In my case (Emtec / Intuix) the issue appeared to some kind of corruption of the firmware. In the end I found: The tool that was provided here solved the write protect issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.